Unable to see qemu devices added to openbalena

I’ve used an image downloaded from balena cloud and configured it with my app on open balena. However, when I start the instance, I’m unable to view the device using balena devices command

Hi, what OS version are you using? Also, does balena scan work?

I’m using Ubuntu Xenial (16.04.1). balena scan says it found no devices (it asks me to run as sudo)

Edit: I think you wanted to know the Balena OS version, it is qemux86-64 v2.38.0-rev1

And what CLI version are you using?

CLI version is 12.14.0

Can you try downgrading the cli to version 12.2.2 and try again please?

Sure, I can try. Should I reconfigure the image or just doing balena devices is enough?

I’ve downloaded the OS image using balena cloud, would that have any impact?

Try without reconfiguring the image

I just tried with balena-cli v12.2.0.
I stopped the VM, then configured the image using balena-cli. The restarted the VM and checked balena devices and balena scan, both returned nothing

Ok. Can you write down the steps and commands you used for each step? We’d like to replicate exactly on our side too

curl "https://api.balena-cloud.com/download?deviceType=qemux86-64&version=2.38.0+rev1.dev&fileType=.zip" --output sample.img.zip

unzip sample.img.zip

balena os configure balena-cloud-qemux86-64-2.38.0+rev1-dev-v9.15.7.img --app myApp

qemu-system-x86_64 -drive file=balena-cloud-qemux86-64-2.38.0+rev1-dev-v9.15.7.img,media=disk,cache=none,format=raw -net nic,model=virtio -net user -m 512 -nographic -machine type=pc,accel=kvm -smp 4 -cpu host

Those are the commands/steps I’ve used

Thanks for the details. When you log in the qemu instance, can you check if the vpn is up? You can do that using the journalctl --no-pager -u openvpn command.

It is up.

Aug 12 17:11:31 deepbeast systemd[1]: Starting OpenVPN service…
Aug 12 17:11:31 deepbeast systemd[1]: Started OpenVPN service.

I’m not sure if this is relevant here, but the container logs for cert-provider has the below error message

[Error] ACTIVE variable is not enabled. Value should be “true” or “yes” to continue.
[Error] Unable to continue due to misconfiguration. See errors above. [Stopping]

Hello Anil,
Glad it worked out for you. I think I sent a response for the error in container logs you are seeing in the other thread that was open, but I am posting the same here to conclude this thread as well.

Regarding the cert_provider container logs you posted. This is expected behaviour as the ACTIVE variable is for toggling ACME certification on and off in the Openbalena server. If your Openbalena server is working fine and you don’t need ACME certification then you can disregard this error. Thanks!

[1] https://github.com/balena-io/open-balena/blob/d70c2177ffa8f0d15449f1a2c10d31d7322a0cc8/compose/services.yml#L185
[2] https://github.com/balena-io/open-balena/blob/c58ee37f175a15747fa27d714e717d2131289c20/src/cert-provider/cert-provider.sh#L80

Also, please let us know if your original problem with the devices not showing up got solved.

No, it did not get resolved.


Hello, could you also paste the supervisor logs from the qemu instance? I wonder if there is some issue in the communication between the device and the open balena server. You can extract the supervisor logs with journalctl --no-pager -u resin-supervisor.

There are no entries in the logs

That is unexpected, can you double check if the spelling is correct? If you still don’t see them can you try running systemctl list-units --type=service | grep supervisor This should the supervisor service status. Just to be clear, this has to be run inside the device (or inside the VM in this case)