Manifest for balenalib/intel-nuc-node:17.4 not found manifest unknown: manifest unknown

I’m getting the below errors when I try and build for an intel-nuc-node:17.4

The reason I’m restricting to 17.4 node version is because I need my node server to work with Raspberry Pi 4 Balena OS as well. Is there a list of the various node versions supported with the different devices for Balena OS? Any assistance is apprecaited.


1 Like

The below image is the reason I made the choice for Node Version 17.4 as I am using Raspberry Pi 4 and Intel Nuc, and thought from the below table that 17.4 would work for both?

1 Like

It seems that the nodejs LTS version is 16.14.0, which is in the balenalib docker images for both the amd64 and aarch64, I believe:

Hence I’ll change to 16.14 for the version of our nodejs from 17.4, hopefully this will solve this issue.

1 Like

This has not solved the issue, I am getting the same error for the intel_nuc build.

1 Like

Usually means the image isn’t available, probably because the build hasn’t been run or failed on Balena’s end where they build the images. The Balena images are a little patchy, I often come across missing images.

Are you using anything on the device that requires the Balena official images? I ended up just using the official node images, they are more predictable and versioned nicely. Also smaller.