Make device " forget" old connections


Somehow my device is remembering old connections. I’ve replaced one cellular configuration file (under /resin-boot/system-connections/) with a new one (because I changed the SIM card) but it wouldn’t connect. Then while debugging it with mmcli on the web terminal it showed the bearer was still using the apn from the previous connection. I tried to delete the bearer but it was stuck on a “disconnecting” state. Then I tried different mmcli commands and reboots but at the end I only managed to solve the problem by changing the name of the file and connection id string inside it, and somehow it forgot previous configurations and it then worked.

On a following step I then removed the wifi configuration file from the same directory and rebooted to see if the device would connect via cellular only but it still connects to the wifi, even though the wifi config file there anymore.

I tried grepping the resin-boot and resin-data partitions but found nothing related to my old connections in there.

So these events above make me think there is a cache somewhere linking my device with its configuration, maybe on the resin server side? If that’s true, how can I make the device “forget” those old connections?

Device: raspberrypi3 with Resin OS 2.9.6+rev1 (dev)


Hey @iggar , so the way the /boot/system--connections folder works, is that on boot of the device, all the files there are basically copied into /etc/NetworkManager/system-connections/ and that is where NetworkManager reads and manages them from. This copy does not delete already existing files (but should overwrite files with the same name).

One thing I often do, if there is a stubborn connection, is to remove the connection using nmcli c delete <CONNECTION_NAME> where CONNECTION_NAME is obtained from nmcli c listing. What this does is delete the corresponding file in /etc/NetworkManager/system-connections.

Thanks @shaunmulligan, I was able to delete the other cellular networks but not the wi-fi.

nmcli c now outputs this:

I then tried deleting the one I assumed was the wi-fi but got errors:

bash-4.3# nmcli c delete [[32mresin-wifi-01[[0m
Error: unknown connection '[[32mresin-wifi-01[[0m'.
Error: cannot delete unknown connection(s): '[[32mresin-wifi-01[[0m'.
bash-4.3# nmcli c delete 32mresin-wifi-01
Error: unknown connection '32mresin-wifi-01'.
Error: cannot delete unknown connection(s): '32mresin-wifi-01'.

Hey, I’ve just found the target directory for the persistent system-connections under:

I’ve then deleted the old ones from there and it’s all good now. Problem solved!

Thanks again!