Luanch URL not working

I have an issue with chrome.
I am getting below error when accessing device on a browser. using http://MyDeviceIP
We encountered an error when reaching this balena.io device:

UUID 8396300de774bdd5f50d51ea3ff3fe48

tunneling socket could not be established: 500

One possible reason is because nothing is listening on port 80 on the device.

NOTE: I have exposed port 80 in a code.

Here is a link to the device summary:
https://dashboard.balena-cloud.com/devices/8396300de774bdd5f50d51ea3ff3fe48/summary

I’ve activated support access.

Hello! Please make sure you set the ports setting for the desired container on your docker-compose.yml file. See here for an example: Communicate outside the container - Balena Documentation

Hi,

This is still not helping,

I am getting below errors in the log

 main  52.4.252.97 - - [23/Jun/2022:15:57:41 +0000] "GET / HTTP/1.1" 404 548 "https://dashboard.balena-cloud.com/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.0.0 Safari/537.36" "-"

Link to device summary: balena dashboard

Hello, I see in your latest release that you are using a single service. Since single service fleets always use host networking, port 80 should be exposed. By default, the Nginx HTTP server listens for inbound connections and connects to port 80, so unless you’ve changed that default, you should be set. The log snippet you posted is actually from NGINX’s access log, showing that a client (such as a web browser) has connected to the device and tried to pull the default page (“\”) from the server, but it was not found. Please make sure you have a default file (typically named index.html) in the NGINX document root. That location is usually defined in your NGINX conf file and often defaulted to /usr/share/nginx/html . Your device is offline now, so I’m not able to confirm.
Also, you may want to check your power supply, as the device is showing an “undervolt” warning. It should be at least 5V, 2.5A. Anything less can cause erratic and difficult-to-diagnose behavior.

Hi Alan,

Thank you for your reply, I have kept my index.html file at the /var/www/html i have also mentioned the path in my conf file.

I have also now changed my power source and fixed the under power issue, However I am still facing this issue.
Can you please guide me through?

hello,

It looks like your nginx configuration is very wrong : /etc/nginx/conf.d/default.conf

        # Everything is a 404
        location / {
                return 404;
        }

You need something in the like of :

server {
        listen 80 default_server;

        root /var/www/html;

        index index.html index.htm;

        location / {
                try_files $uri $uri/ =404;
        }
}

Hi Edwin,

Even this solution is not helping me, I am still getting the same error.