Local mode push freezes after "Probing remote daemon for cache images"

Hi folks,
I am trying to push my images in local mode. I am using Supervison 12.2.11 and balena-cli 12.37.1, but how many times I retry I get stuck at “Probing remote daemon for cache images”. Tried to turn the local mode on and off but still getting the same error. The machine has internet access and I can manage it from balenaCloud.

Possibly related topic: Localmode push hangs

>> balena push --debug
[debug] new argv=[/usr/local/lib/balena-cli/bin/node,/usr/local/lib/balena-cli/bin/run,push,] length=4
[Debug]   Using build source directory: .
[Debug]   Pushing to local device:
[Debug]   Checking we can access device
[Debug]   Sending request to
[Debug]   Checking device version: 12.2.11
[Info]    Starting build on device
[Debug]   Loading project...
[Debug]   Resolving project...
[Debug]   docker-compose.yml file found at "."
[Debug]   Creating project...
[Debug]   Tarring all non-ignored files...
[Debug]   Sending request to
[Debug]   Found build tasks:
[Debug]       service1: build [./service1/]
[Debug]       service2: build [./service2/]
[Debug]       redis: image pull [redis:alpine]
[Debug]   Resolving services with [raspberrypi4-64|aarch64]
[Debug]   Found project types:
[Debug]       service1: Dockerfile.template
[Debug]       service2: Dockerfile.template
[Debug]       redis: External image
[Debug]   Probing remote daemon for cache images

Thank you for checking it out and thank you for your support.

Hey @jyviko, I’m not able to reproduce your issue yet. Can you try connecting to the device via ssh and run balena image ls to see if there’s an error?

It may also be helpful to run Diagnostics -> Device Health Checks in the dashboard to see if there are any issues flagged.