Linux version balena-cli does nothing in windows subsystems for linux

resin-cli

#1

I have tried both the standalone installation as well as the npm installation, and upon running either of these things, no matter what options I try to pass in, it just prints null and exits.

I am running on the windows subsystem for linux bash terminal, which should just be a ubuntu instance as far as a program like this is concerned.
Is there a particular hardware requirement that it needs access to in order to function properly? Has anyone else encountered this?


#4

Running with sudo makes it work… is this strictly necessary?


#5

What commands are you running and exits with null? What CLI versions have you tried?


#6

I am using 9.7.0, I tried with the standalone and the npm package.

All commands regardless of arguments simply print null when running without sudo.


#7

@bathtubed can you please give the latest CLI version a go and file an issue on the project issue tracker if it persists?


#8

I think it’s fixed now?

In trying to update with npm, it told me that I needed to run some chown command on ~/.config, which allowed me to update, but it also allowed me to run the cli without sudo BEFORE I updated, on 9.6.

To be honest, I have no idea what I did that caused it to start working without sudo.