Installation of Balena0S on Nvidia Orin NX stuck at the end

Hello,

I have installed BalenaOS successsfully in the past on a RaspberryPI and on a Jetson Xavier AGX.

Nonetheless, I am stuck with the flashing process on a Nvidia Orin NX. It’s not exactly the devkit but it is embedded in a syslogic computer. However, the process should be quite similar because they refer the the nvidia documentation of the devkit to explain how to flash the computer again.

I have tried to follow the instructions frm the github repository. I am able to place the computer in recovery mode, to start and run the docker, the flashing process does not seem to show critical issue. Finally, the LED switches off after around 15 minutes. But when I switch my board off and on, I am still on the previous OS version, BalenaOS is not present. I tested on the Nvidia default dev kit and on another PC based on the orin NX module but I face the same issue on both

I really struggle to understand what is going on, since I cannot find a way to show the result of the flashing process from the USB to the Jetson QSPI memory.

Have anyone encountered the same problem and do you have any idea on how to get out of this? I thought that versions could be an issue but I am not sure.

  • Host PC: Ubuntu 22.04.4 LTS (6.5.0-35-generic)
  • Docker version 26.1.3, build b72abbb
  • Hardware: Nvidia Jetson Orin NX 16GB in a SYSLOGIC RML A4NX compter
  • BalenaOS: 5.3.10 (I cannot find on which L4T this is based)
  • Jetson-flash: on master branch

Thanks you!

1 Like

Hello @gurbain first of all welcome to the balena community!

What device type did you test on balena?

I’m using NVIDIA Jetson Orin NX 16GB from Seeed Studio which is this device type Seeed reComputer J4012 16GB.

Hi @mpous,

I have tried with this device: ZED Box - Orin NX 16GB for Edge AI | Stereolabs
And this one: Rugged Computer RPC RML A4NX (GMSL)

With similar (non-conclusive) results. I know they are not the official dev kits but they are based on the same NX module and at least the later allow firmware update with the official nvidia NX devkit device tree and image.

I don’t know where to start since I’m unable to see the logs about what’s going on as soon as the memory transfer from the USB key to the PC happens.

@gurbain i understand your pain! I also had similar issues with the reComputer.

Are you using those devices for any specific requirement?

Do these manufacturers have the bsp layers for Yocto or any specific dtoverlay or dtparams?

I pinged internally the devices team to see how we can help you more!

Hi @gurbain , regarding this:

Could there be more than 1 internal storage present in the Syslogic board?

Since the device appears to boot the USB flasher image and turns off after provisioning is completed, it could be that there is a NVME present and it is flashed, but it then continues to boot from another NVME, SSD, SD-CARD etc, which has Ubuntu flashed on it. You could check from the previous OS, if this is the case.

I also recommend checking if the devices have any debug UART port to collect logs during flashing. That might require to open the device’s case.

Once you get access to the debug uart, you can use a Development image for provisioning, and login with user root to check if flashing works using: journalctl | grep flasher
and
systemctl status resin-init-flasher.

Hi,

@mpous : yes, I use it mainly because of their GMSL2 and CAN connection and the second one also for its mechanical properties (IP protection, casing, thermal, EM, …).
No, I could not find any BSP layers for it. I know someone required it on for the stereolabs device on the stereolabs forum but no real answer there.

@acostach: that’s actually a very interesting comment. I did not think about double memory… About the UART, are we talking about UART0 Interface of the Jetson ORIN NX Module (I can have access to this one) or another one?

Unfortunately, I will be away from these computer for the next 2-3 weeks but I will test this, afterwards, as soon as I can and post it if I find anything.

1 Like

Keep us posted @gurbain !