Installation of Balena not pushing thru

Hi, can someone assists mo during my installation of balena os on my pc. The pc suddenly shutdown. I thought the os installation was finisher. When I try to open it again. No operating system is found. Is my hard drive has the problem or my usb device? Thank hou


Thanks for reaching out. To help us figure out what is happening here, can you let us know which OS version you tried to install, and for which device type?


I downloaded the Generic x86_x64(New) OS for my intel core i3 PC with a memory of 8gb RAM. Do i downloaded the correct OS for windows?

Thank you!


Just to make sure I get this correctly, can you confirm that you are trying to install balenaOS on your pc? I believe you have a second computer as your main machine and are trying to install balenaOS on a second one(with intel i3)?

Please note that installing this on a pc will erase all data on the disk

To install balenaOS on a pc, you should

  • Download the balenaOS image - you mentioned you downloaded the Generic x86_x64(New) OS which should work for your pc
  • Flash the os on a usb pendrive using balenaEtcher
  • Plug the pendrive in the target pc you want to flash balenaOS to
  • When booted, balenaOS should be flashed to the internal disk. The pc will indeed shutdown.
  • You can now remove the USB drive and press the power button once again.

Can you also confirm how you downloaded the balenaOS image? Do you have a balenaCloud account?


Yes I’m trying to install BalenaOS to my spare PC. I get the installer(Generic X86_x84(new))on the site below and follow the steps. But after the installation the PC suddenly shutdown when I try to open it. It says no operating system found.


Can someone help me???

Tried to use Intel Nuc and Microsoft Surface 60 still no operating system found after the shutdown. Hope someone can help me with this.

Also noticed after creating a flash installer. The USB created many partitions from drive D-G that requires formatting to access it Is it normal? I just ignore it and proceed to installation to my PC. Please see picture.capture2

Sending also the output of Flash installer

I have downloaded etcher from and same problems I am facing can anybody tell me how to solve this issue and I need legal balena software and the software i downloaded is not working properly. kindly provide me the proper download link

1 Like

Hello @ian-dealday, yes the partitions and associated messages are normal after flashing and can be ignored. The output of the flashed drive also looks correct. Once your PC shuts down after installation, are you removing the USB drive and then powering on again? Is that the point at which you are getting the “no operating system” message? If so, can you confirm your machine is set to boot to the internal HDD you just flashed?

@hendricks the official balena Etcher site is: balenaEtcher - Flash OS images to SD cards & USB drives where you can download the latest version.