A start job is running for Resin for an hour?

Just booted from USB and had to boot with ‘nomodeset’ since all flavors of Linux won’t boot on my desktop without it. “NVIDIA BUG”
It’s stuck on running for Resin.

Hi @Sandman192. Welcome to the balena forums.

Can you give more information about what you’re trying to do? For example:

  • Are you following some example documentation or recipe we can take a look at?
  • What OS are you trying to boot and where did you download it?
  • How did you write the USB image?
  • What exactly is the hardware?


balena x Rosetta using Etcher flasher
ASRock 4CoreDual-SATA2 with NVIDIA Corporation GT218 [ION] graphics card

So this is an OS image you downloaded from fold4covid.io? Regarding the hardware, can you give us an exact model number so that our devices team can look up the specs? Thanks.

Yes it’s from foldforcovid.io. DL it today.
The ASRock 4 CoreDual-SATA2 is the Mobo model number.

P.S. I got Mint to run but only in ‘nomodeset’ only.

We’ll get to the bottom of this!

Can you please try to re-flash the USB, boot from it and then take a photo of the screen and the log output that it shows? It would really help us to understand what is happening.


Heck, I’ll even redownload it. But with flavors of Linux I have to boot in ‘nomodeset’ even from live boot) to get the desktop up and running because of the NVIDIA bug. I even turn off all onboard devices.
Still stuck.

Does it remain on that exact screen indefinitely? Failing to start the ‘resin-init-flasher’ may indicate that it cannot find a local hard disk to install to. What kind of hard disk do you have, and, it is properly attached? Does the PC’s BIOS / UEFI recognize the disk? Thanks.


The BIOS (no UEFI on this board) sees 2 of my HDs.

Note: I’ve tried CentOS and it wouldn’t see the drives but the OS did boot from the USB. But Mint did see the HDs and did install it.

Sounds like difference in what the kernels support out of the box then, between the CentOS and Mint installations. In this case, if balenaOS does not recognize the drives, you’d have to end up building your own spin of the OS from source, and then manually installing the balenaCloud version of Fold for Covid in order to get it running the project. The tricky part is going to be determining exactly what kernel module your system needs, but in the meantime you can read about the process of building from source here: https://www.balena.io/os/docs/custom-build/

You will want to replace those references to Raspberry Pi, with these Intel sources however: https://github.com/balena-os/balena-intel

Give me something.

I couldn’t even get a simple program to install like Prime95 even after I read the instructions. I tried the terminal with error after error of trying to install the stupid thing and failed.

YOU WANT ME TO RETRANSLATE RASPBERRY PI TO A STANDARD DESKTOP. Again I couldn’t even install a program I downloaded from a Linux desktop.

I am tech savvy but Linux is a whole nother ballpark. DOS is more easier than Linux. But there are no programs for DOS that I want to use for.

Give me step by step and tell who developed of Linux is still a LONG WAY OFF of making it easier and claims to be more compatible with older PCs. NOT!

Give me step by step for desktops or I will never get this off the ground and to boot in ‘nomodeset’ due to a NVIDIA bug.

Oh wow. I get no more response for 3 days.

One give me on how to do a custom install for RASPBERRY PI on a desktop!! What!

I don’t know anything about Linux… It was supposed to be easy to get it running according to the site. Install, login and run work. But since there’s seems to be a hardware bug from linux I can’t get it running. How about reporting it to Linux Devs to fix it.

I chose Linux because it’s free and it’s not a memory hog. I have Windows 10 w/o any startup app running at all and it’s taking up 6 gigs of memory just to run Windows. I have 2 gigs ram max. This board is a strange one when it comes to max RAM.

I even tried another HD card and another HD. Linux sees it but gets stuck there saying the same thing on my first Picture I posted before.

Hey - thank you for your patience. We try our best to respond to all of our forum posts as quick as we can, but not all issues are quick to solve. Your particular system seems quite tricky to get Linux to run on, since there is such a difference between particular distro’s.
Given that you say:

I don’t know anything about Linux

I don’t think we are going to be able to talk you through a custom setup which will work. However, we are currently testing a Live USB image of balenaOS spectifically with Fold4Covid users in mind. It is worth you waiting for this (no ETA but it’s in testing) and trying again when this is released.

Thanks again for the patience.

I want to know if this is going to be put as an OS bug because I can’t boot from a live USB? I don’t want commands. Boot up and go has gone up and went.

The OS should run without doing any commands. balenOS should be boot and go, which it seems to be not seeing an HDD bug. Which I don’t get since it’s a soo basic hardware that even any version of DOS that I heard of can run on.

I was told it COULD be an HDD issue. BUT… I even tried a different SATA HD controller. Nope.

P.S. Mint is just as bad when they created a very basic NVIDIA bug. No, it’s not the drivers because I can’t even boot from a live USB without 'a ‘nomodeset’ command. I can’t run video drivers without being stuck at boot.

@Sandman192 this Fold for Covid image of balenaOS is not a live USB Linux OS, it does not support all hardware and as such will not work on as many different computers as other distributions do. It sounds like for now it doesn’t work on the computer you have. As Phil mentions above a live USB version is something we’re working on, but it’s not available yet. In addition we’re adding support for more computers all the time and so it may work in the future.