How to Flash with MacOS 11(Big Sur)-Checksum Error

I’ve been working on this for weeks and dizzy from reading different forums on what to do and the issue. Will someone just please tell me what to do? I’ve been flashing USB sticks for years and never had this many issues.

Here is what I’m using:
MacMini MacOS 11.2.3
MacBook Catalina
Two different carriers for SD cards
Three different SanDisk cards
Etcher, dd, and Rasberry Pi Imager

All of the combinations give me the same error. Here is the last thing I tried. I reformatted the card as MBR Fat 32. I run Etcher on the card.
MacOS then asks: Eject, Ignore, Initialize…

I’m not sure which one to pick. I think Ignore will not allow me to do anything with the drive so I pick Initialize. Now the card shows an Apple Partition Map disk and a FAT12 volume with 5.1M.

I’ve tried this with a many different Raspberry Pi OSes. The last one I used is Buster. This has me so aggravated I can’t think straight anymore. I’m looking for a straight up answer and yes I’ve rebooted:)

Hi, ignoring the message should be fine, it just means the OS won’t perform any operations on the target you just connected and Etcher will still be able to read it.
Now on the specific issue, did you try changing media reader? So if it’s a sdcard slot on your mac, trying with a usb card reader for example, or changing usb reader if you have one spare, as it can make a difference in some cases

Hi Thundron. Thank you for the response. I would not be bothering anyone if it worked. Nothing comes up on my Pi when I put the chips in it. I have two USB media readers I’m using: CoCooka and Sinstar. I have the same results with either one.

Should I Etcher create an Apple partition and FAT12 volume when flashing a Raspberry PI OS? I thought it would be FAT16 or 32.

Oddly, I had a similar issue on downloaded balena project images. I found the solution was to OPEN the image first, then unmount it and then open etcher and re-try to flash from the image.

Not sure why it works but it always does for me.

@drewgolden I’ve worked with computers a long time, but not with data. I’m more on the networking side. I guess I’ve been spoiled because it always just worked before. So I don’t understand what you are saying. Are you saying delete Etcher from Applications and download again. Then open it, cancel the install, unmount it, and then install from the dmg file to create the app file? Or are you talking about the RaspOS file?

I’m going out of town in a bit where there is no Internet until Sunday so when I don’t reply back it is not because I’m not interested and will get back to you by Monday.

Hi @anom, are these new SD cards? Have you tried doing “Initialize” on one of them? What are the results?

Do you get any errors on Etcher itself?

Could you post the Etcher console output (you can get it by doing Cmd+I or through the View Menu > Toggle developer tools). Could you also share your Etcher version?

Thank you

One card was new and the other one was not. I can write files to both. What would tell me if a card was bad? I ran checks on both of them. I have tried Initialize before and after flashing. I’ve tried flashing probably 20-30 times with different combinations.

I get the checksum error that is discussed in a lot of forums. I’m using version 1.5.113 right now. I did not know about the Cmd+i option. I’ll try that Monday and let you know.

Are you trying to burn an OS image file? Mac OS can open the image file to validate it’s a good image. I was getting errors from etcher on images I would download from So I discovered that OPENING the images and then closing / unmounting the image was enough to allow etcher to open and write the image to an SD card. For example I downloaded balena-cloud-Balena_ADS-B-raspberrypi4-64-2.73.1+rev1-dev-v12.4.6.img but it would not write with etcher to the sd card. Open it, then unmount it - and magically it works and will burn to the SD card without error.

Here is the log data from the Developer Tools when I tried to flash an ISO to a card. I’m going to try DrewGolden’s idea now.

Verifying 1 device, 99% at 9.80 MB/s (total 9.80 MB/s) eta in 1s with 0 failed devices

gui.js:56875 Mon Apr 12 2021 12:59:21 GMT-0400 (Eastern Daylight Time) Validation error ({“image”:{“size”:3091660800,“name”:“2021-01-11-raspios-buster-i386.iso”,“hasMBR”:true,“partitions”:[{“offset”:2697216,“size”:5128192,“type”:239,“index”:1}],“extension”:“iso”,“path”:"/Volumes/Rasberry Pi/2021-01-11-raspios-buster-i386.iso"},“drives”:[{“size”:64424509440,“isVirtual”:false,“enumerator”:“DiskArbitration”,“logicalBlockSize”:512,“raw”:"/dev/rdisk3",“error”:null,“isReadOnly”:false,“displayName”:"/dev/disk3",“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"/dev/disk3",“busVersion”:null,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:“IODeviceTree:/PCI0@0/XHC1@14”,“mountpoints”:,“description”:“Generic MassStorageClass Media”,“isUAS”:null,“partitionTableType”:null}],“driveCount”:1,“uuid”:“279a50ca-a183-484d-bc6f-daae9448a0f9”,“flashInstanceUuid”:“279a50ca-a183-484d-bc6f-daae9448a0f9”,“sample”:0.1,“applicationSessionUuid”:“75d627b7-24e9-4741-97be-3a5404659629”,“flashingWorkflowUuid”:“84fdd1b8-e7f2-4034-a825-f3b2a6ede2c6”})

gui.js:6038 Verifying 1 device, 99% at 10.20 MB/s (total 10.20 MB/s) eta in 0s with 0 failed devices

gui.js:56875 Finish: 3089104896

gui.js:56875 Terminating IPC server

gui.js:56875 Flash results

  1. {results: {…}, cancelled: false, skip: false}

gui.js:56875 Mon Apr 12 2021 12:59:23 GMT-0400 (Eastern Daylight Time) Done ({“image”:{“size”:3091660800,“name”:“2021-01-11-raspios-buster-i386.iso”,“hasMBR”:true,“partitions”:[{“offset”:2697216,“size”:5128192,“type”:239,“index”:1}],“extension”:“iso”,“path”:"/Volumes/Rasberry Pi/2021-01-11-raspios-buster-i386.iso"},“drives”:[{“size”:64424509440,“isVirtual”:false,“enumerator”:“DiskArbitration”,“logicalBlockSize”:512,“raw”:"/dev/rdisk3",“error”:null,“isReadOnly”:false,“displayName”:"/dev/disk3",“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"/dev/disk3",“busVersion”:null,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:“IODeviceTree:/PCI0@0/XHC1@14”,“mountpoints”:,“description”:“Generic MassStorageClass Media”,“isUAS”:null,“partitionTableType”:null}],“driveCount”:1,“uuid”:“279a50ca-a183-484d-bc6f-daae9448a0f9”,“status”:“finished”,“flashInstanceUuid”:“279a50ca-a183-484d-bc6f-daae9448a0f9”,“errors”:[{“name”:“Error”,“description”:“Generic MassStorageClass Media”,“code”:“EVALIDATION”,“device”:"/dev/disk3"}],“devices”:{“failed”:1,“successful”:0},“bytesWritten”:3089104896,“sourceMetadata”:{“size”:3091660800,“name”:“2021-01-11-raspios-buster-i386.iso”,“blocks”:[{“blocks”:[{“offset”:0,“length”:3091660800}]}],“blockmappedSize”:3091660800},“sample”:0.1,“applicationSessionUuid”:“75d627b7-24e9-4741-97be-3a5404659629”,“flashingWorkflowUuid”:“84fdd1b8-e7f2-4034-a825-f3b2a6ede2c6”})

This may not matter, but the card will not eject with the Disk Utility app or unmountDisk in a terminal after running Etcher. I close Etcher when done because the app tells me another app is still using the card. The command: ‘diskutil unmountDisk /dev/disk3’ says unmounting worked: ‘Unmount of all volumes on disk3 was successful’, but the card still shows up:
/dev/disk3 (external, physical):
0: Apple_partition_scheme *64.4 GB disk3
1: Apple_partition_map ⁨⁩ 4.1 KB disk3s1
2: Apple_HFS ⁨⁩ 5.1 MB disk3s2

Opening the image file, unmounting, and then running Etcher also failed:

Verifying 1 device, 20% at 9.80 MB/s (total 9.80 MB/s) eta in 122s with 0 failed devices

gui.js:56875 Mon Apr 12 2021 13:46:50 GMT-0400 (Eastern Daylight Time) Validation error ({“image”:{“size”:1862270976,“name”:“2021-01-11-raspios-buster-armhf-lite.img”,“hasMBR”:true,“partitions”:[{“offset”:4194304,“size”:268435456,“type”:12,“index”:1},{“offset”:272629760,“size”:1589641216,“type”:131,“index”:2}],“extension”:“img”,“path”:"/Volumes/Rasberry Pi/2021-01-11-raspios-buster-armhf-lite.img"},“drives”:[{“size”:64424509440,“isVirtual”:false,“enumerator”:“DiskArbitration”,“logicalBlockSize”:512,“raw”:"/dev/rdisk3",“error”:null,“isReadOnly”:false,“displayName”:"/dev/disk3",“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"/dev/disk3",“busVersion”:null,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:“IODeviceTree:/PCI0@0/XHC1@14”,“mountpoints”:,“description”:“Generic MassStorageClass Media”,“isUAS”:null,“partitionTableType”:null}],“driveCount”:1,“uuid”:“d34bc56f-b3fc-46ea-80a5-57cd572eff2d”,“flashInstanceUuid”:“d34bc56f-b3fc-46ea-80a5-57cd572eff2d”,“sample”:0.1,“applicationSessionUuid”:“2aebccf3-a566-47eb-bb60-be7fd6b4f4bc”,“flashingWorkflowUuid”:“0d46b740-8eca-49a1-99ec-5c8481a96000”})

gui.js:6038 Verifying 1 device, 20% at 9.80 MB/s (total 9.80 MB/s) eta in 121s with 0 failed devices

gui.js:56875 Finish: 314572800

gui.js:56875 Terminating IPC server

gui.js:56875 Flash results

  1. Object

gui.js:56875 Mon Apr 12 2021 13:46:52 GMT-0400 (Eastern Daylight Time) Done ({“image”:{“size”:1862270976,“name”:“2021-01-11-raspios-buster-armhf-lite.img”,“hasMBR”:true,“partitions”:[{“offset”:4194304,“size”:268435456,“type”:12,“index”:1},{“offset”:272629760,“size”:1589641216,“type”:131,“index”:2}],“extension”:“img”,“path”:"/Volumes//Rasberry Pi/2021-01-11-raspios-buster-armhf-lite.img"},“drives”:[{“size”:64424509440,“isVirtual”:false,“enumerator”:“DiskArbitration”,“logicalBlockSize”:512,“raw”:"/dev/rdisk3",“error”:null,“isReadOnly”:false,“displayName”:"/dev/disk3",“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"/dev/disk3",“busVersion”:null,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:“IODeviceTree:/PCI0@0/XHC1@14”,“mountpoints”:,“description”:“Generic MassStorageClass Media”,“isUAS”:null,“partitionTableType”:null}],“driveCount”:1,“uuid”:“d34bc56f-b3fc-46ea-80a5-57cd572eff2d”,“status”:“finished”,“flashInstanceUuid”:“d34bc56f-b3fc-46ea-80a5-57cd572eff2d”,“errors”:[{“name”:“Error”,“description”:“Generic MassStorageClass Media”,“code”:“EVALIDATION”,“device”:"/dev/disk3"}],“devices”:{“failed”:1,“successful”:0},“bytesWritten”:314572800,“sourceMetadata”:{“size”:1862270976,“name”:“2021-01-11-raspios-buster-armhf-lite.img”,“blocks”:[{“blocks”:[{“offset”:0,“length”:317718528}]},{“blocks”:[{“offset”:406847488,“length”:101711872}]},{“blocks”:[{“offset”:512753664,“length”:793772032}]},{“blocks”:[{“offset”:1307574272,“length”:189792256}]},{“blocks”:[{“offset”:1522532352,“length”:1048576}]},{“blocks”:[{“offset”:1524629504,“length”:6291456}]},{“blocks”:[{“offset”:1561329664,“length”:1048576}]},{“blocks”:[{“offset”:1563426816,“length”:1048576}]},{“blocks”:[{“offset”:1632632832,“length”:16777216}]},{“blocks”:[{“offset”:1650458624,“length”:2097152}]},{“blocks”:[{“offset”:1656750080,“length”:8388608}]},{“blocks”:[{“offset”:1673527296,“length”:58720256}]}],“blockmappedSize”:1498415104},“sample”:0.1,“applicationSessionUuid”:“2aebccf3-a566-47eb-bb60-be7fd6b4f4bc”,“flashingWorkflowUuid”:“0d46b740-8eca-49a1-99ec-5c8481a96000”})

Did this stump everyone? No more help?

Hey @anom, sorry for the delayed response. It does appear that you’ve tried a lot already so we don’t want to suggest to retry any steps.

To summarize for myself and other agents, you’ve tried:

  • 2x different MacOS workstations (MacMini MacOS 11.2.3, MacBook Catalina)…
  • 2x different brands of SD cards…
  • 3x different SanDisk cards…
  • 3x flashing applications (Etcher, dd, Rasberry Pi Imager)…
  • Many versions of Raspberry Pi OS…

If the above is all correct (please tell me if not) then it seems not to be an issue with the SD cards, nor the workstation, nor balenaEtcher. Have you asked about this on the Raspberry Pi forums yet?

Have you tried flashing images besides Raspberry Pi OS? What about a balenaOS image from balenaOS - Run Docker containers on embedded IoT devices as a test?

Hi @klutchell , You are correct. I have tried all the things you mentioned except brands of SD cards as they are all SanDisk. I have also tried different images and ISO files like Kali. I have not asked on other forums as this one seemed to have the best responses with similar issues.

I purchased another card and tried it. It worked. It seems I never have this issue when flashing the first time on a card. That is why I kept reformatting the card before trying. It seems I can’t wipe a card back to the original state after I flash it the first time and this causes MacOS and Ubuntu Server to do something different. I spun up an Ubuntu Server fully patched and tried Etcher with a not-new card. It failed as well with the same checksum error.

Hey @anom, I apologize I didn’t see your last response until now.

Following the theme of recovering your SD to factory defaults, have you tried the recovery methods listed here?

I suggest starting with your new Ubuntu installation first, as I would be very surprised if dd could not completely wipe your SD card.

I used MacOS since Umbuntu is not going to be around. It seemed to work, but still failed.
Here is the ‘diskutil list’ before wipe:
/dev/disk3 (external, physical):
0: FDisk_partition_scheme *64.4 GB disk3
1: Windows_FAT_32 ⁨boot⁩ 268.4 MB disk3s1
2: Linux ⁨⁩ 1.6 GB disk3s2
(free space) 62.6 GB -

After wipe:
/dev/disk3 (external, physical):
0: FDisk_partition_scheme *64.4 GB disk3
1: DOS_FAT_32 ⁨UNTITLED⁩ 64.4 GB disk3s1

After Etcher flash of Buster light:
/dev/disk3 (external, physical):
0: FDisk_partition_scheme *64.4 GB disk3
1: Windows_FAT_32 ⁨boot⁩ 268.4 MB disk3s1
2: Linux ⁨⁩ 1.6 GB disk3s2
(free space) 62.6 GB -

Here are the errors from developer window:
Verifying 1 device, 21% at 9.80 MB/s (total 9.80 MB/s) eta in 121s with 0 failed devices

gui.js:56875 Finish: 315621376

gui.js:56875 Terminating IPC server

gui.js:56875 Flash results

  1. Object

  2. cancelled: false

  3. results:

1. averageFlashingSpeed: 835421.8319215567
2. bytesWritten: 315621376
3. devices: {failed: 1, successful: 0}
4. errors: Array(1)

  1. 0: Error: Checksum does not match for range [0, 317718527]: "c9f1eba27aede983" != "e4e1ecc8dd6075fb" at verifyOrGenerateChecksum (/Applications/ at Object.createSparseReaderStateIterator (/Applications/ at (<anonymous>) at SparseReadStream.nextBlock (/Applications/ at SparseReadStream.__read (/Applications/ at async SparseReadStream._read (/Applications/
  2. length: 1
  3. __proto__: Array(0)

5. sourceMetadata: {size: 1862270976, name: "2021-01-11-raspios-buster-armhf-lite.img", blocks: Array(12), blockmappedSize: 1498415104}
6. __proto__: Object
  1. skip: false
  2. proto: Object

gui.js:56875 Fri Apr 23 2021 06:54:59 GMT-0400 (Eastern Daylight Time) Done ({“image”:{“size”:1862270976,“name”:“2021-01-11-raspios-buster-armhf-lite.img”,“hasMBR”:true,“partitions”:[{“offset”:4194304,“size”:268435456,“type”:12,“index”:1},{“offset”:272629760,“size”:1589641216,“type”:131,“index”:2}],“extension”:“img”,“path”:"/Volumes/ Documents/Rasberry Pi/2021-01-11-raspios-buster-armhf-lite.img"},“drives”:[{“size”:64424509440,“isVirtual”:false,“enumerator”:“DiskArbitration”,“logicalBlockSize”:512,“raw”:"/dev/rdisk3",“error”:null,“isReadOnly”:false,“displayName”:"/dev/disk3",“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"/dev/disk3",“busVersion”:null,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:“IODeviceTree:/PCI0@0/XHC1@14”,“mountpoints”:[{“path”:"/Volumes/UNTITLED",“label”:“UNTITLED”}],“description”:“Generic MassStorageClass Media”,“isUAS”:null,“partitionTableType”:“mbr”}],“driveCount”:1,“uuid”:“ef484dd3-05e4-4359-a5b4-f1bebd1921a0”,“status”:“finished”,“flashInstanceUuid”:“ef484dd3-05e4-4359-a5b4-f1bebd1921a0”,“errors”:[{“name”:“Error”,“description”:“Generic MassStorageClass Media”,“code”:“EVALIDATION”,“device”:"/dev/disk3"}],“devices”:{“failed”:1,“successful”:0},“bytesWritten”:315621376,“sourceMetadata”:{“size”:1862270976,“name”:“2021-01-11-raspios-buster-armhf-lite.img”,“blocks”:[{“blocks”:[{“offset”:0,“length”:317718528}]},{“blocks”:[{“offset”:406847488,“length”:101711872}]},{“blocks”:[{“offset”:512753664,“length”:793772032}]},{“blocks”:[{“offset”:1307574272,“length”:189792256}]},{“blocks”:[{“offset”:1522532352,“length”:1048576}]},{“blocks”:[{“offset”:1524629504,“length”:6291456}]},{“blocks”:[{“offset”:1561329664,“length”:1048576}]},{“blocks”:[{“offset”:1563426816,“length”:1048576}]},{“blocks”:[{“offset”:1632632832,“length”:16777216}]},{“blocks”:[{“offset”:1650458624,“length”:2097152}]},{“blocks”:[{“offset”:1656750080,“length”:8388608}]},{“blocks”:[{“offset”:1673527296,“length”:58720256}]}],“blockmappedSize”:1498415104},“sample”:0.1,“applicationSessionUuid”:“edd5a8d7-e99f-476f-a2d0-db5a35bc898c”,“flashingWorkflowUuid”:“068e0f63-a6c8-4673-99bf-1c9bbe859feb”})

I can’t normally eject the drive because it says another application is using the device even though Etcher is quit. Disk utility shows the partition as Apple Partition Map (64G) and the volume is not mounted with a capacity of 5.1M. The device also moved from disk3 to disk4?!?. Is there a way to find out what app is hold onto this drive? If I do not find a way to release it and pull the drive out, MacOS holds onto the drive even though it is not connected. I can reboot to clear it, but seems to be an issue.

I really appreciate the help. I feel that I’m not providing the piece of information to resolve this. Is there somewhere in the Console I can look with filters to get some more information about what is going on?

Was that Ubuntu you spun up a VM, running on the Mac? Or a separate, whole other physical machine?

Because based on the experience you are describing, it really sounds like the card reader is failing, or, the OS has some issue / corruption whereby it is not properly controlling, using, and releasing the drive.

I used Etcher about 10 times today on a Mac, and it worked fine. So, I think you have a case of failing hardware or OS corruption there.

The Umbuntu server is on bare metal Mil Spec workstation. I did try a different card reader once on the MacOS Mini. I usually use this other card reader on my MacBook. I mostly use my Mini to test with, but have used the others several times with the same result. The only why I get a card to flash is if it is new. I’ll try wiping the card with Umbuntu this weekend and flashing it there. The only reliable method that works is if I use a new card. There has got to be a log somewhere that tells me what is breaking this.