GPS issue EC25 - Taoglas FXP611 GPS antenna

#1

@dansku Thanks for the amazing article on the GPS tracking.

I followed the article and setup the cellular connection and the Udev rules.

I can see that the devices is getting connected to the cellular but i couldn’t able to access the GPS?

I can see that the GPS is getting detected. “Using autodetected GPS device: /dev/EC25.NMEA”
Getting error “Error enabling GPS

Reference:
Device: Balena Fin
Host OS: balenaOS 2.32.0+rev1

root@884dbb7:~# mmcli -m 0 --command='AT+QGPS=1'
error: command failed: 'GDBus.Error:org.freedesktop.ModemManager1.Error.MobileEquipment.Unknown: Unknown error'

root@884dbb7:~# mmcli -m 0 --location-get

/org/freedesktop/ModemManager1/Modem/0
  -------------------------
  3GPP location   | Mobile country code: '302'
              | Mobile network code: '***'
              |  Location area code: '*****'
              |             Cell ID: '*******'
  -------------------------
  GPS NMEA traces | Not available
  -------------------------
  Raw GPS         | Not available
  -------------------------
  CDMA BS         | Not available
#4

Hi,
I am not familiar with the project so I will forward your request to dansku anyway.
Just to help you debug this meanwhile. I am wondering why you would use network manager to retrieve GPS information. My first approach would be to access the /dev/EC25.NMEA directly device and see if you can get a NMEA data stream.
So for instance with a terminal like screen you could do something like this:

screen  /dev/EC25.NMEA  115200 

where 115200 is the baud rate.
If you see a data stream like this:

$GPGGA,184927.000,0856.1942,N,07933.3292,W,1,11,0.7,51.1,M,1.3,M,,0000*4E
$GPGLL,0856.1942,N,07933.3292,W,184927.000,A,A*4B
$GPGGA,184957.000,0856.1920,N,07933.3308,W,1,10,0.7,50.9,M,1.3,M,,0000*47
$GPGLL,0856.1920,N,07933.3308,W,184957.000,A,A*4A
$GPGSA,A,3,29,31,01,27,16,32,22,20,14,18,,,1.4,0.7,1.2*36

then you are looking at GPS NMEA data .

Regards
Thomas

#8

@samothx Thanks for the response. I tried the above steps but i dont see any data.

#19

Hey @naga,

You won’t be able to get GPS data via the MMCLI unfortunately, it is not yet implemented for the EC25. That is why the article used raw /dev/EC25.NMEA.

The --location-get generally doesn’t work very well on tested modems.

#21

@dansku Thanks for the response.

The reason I was doing via MMCLI is to debug things on my end. I couldn’t get raw NMEA data.

I was getting the "Error enabling GPS: [ ‘Unknown error’ ]: when I get the program which is referenced in the article.

On Testing:

mmcli -m 0 --command=‘AT+QGPS=1’
response: ‘’
root@884dbb7:~# mmcli -m 0 --command=‘AT+QGPSGNMEA=“GGA”’
response: ‘+QGPSGNMEA: $GPGGA,161958.00,4335.990392,N,07938.420899,W,1,03,1.4,161.1,M,-41.0,M,*57’
root@884dbb7:~# mmcli -m 0 --command=‘AT+QGPSEND’
response: ‘’

I did: stty -F /dev/EC25.NMEA 9600 && cat /dev/EC25.NMEA

all I see is an empty screen.

Am I missing anything on my end?

#29

A couple of ideas from our team to follow up:

Does “/dev/EC25.NMEA” exist in your container?

If it does, can you from the host OS try running:
mmcli -m 0 --command=“AT+QGPS=1,30,50,0,5”
and back in the container do a cat /dev/EC25.NMEA

That command will enable the GPS with a sample interval of 5 seconds and should see NMEA messages comming from the “cat” part.

If the mmcli command above fails in some way, that would tell us a bit more as well, maybe the firmware on the modem doesn’t work the same way as ours (newer/older version), or something in the OS version is different? These should help to get a deeper understanding of the problem.
Thank you!

#31

@imrehg “/dev/EC25.NMEA” exist in the container.

Host OS:

mmcli -m 0 --command=“AT+QGPS=1,30,50,0,5”
error: no actions specified

Container

cat /dev/EC25.NMEA

is empty

any thoughts?

Please do let me know if you need anymore info from my end

#43

My apologies, not sure, how the paste changed the quote marks, and the command should have been:

mmcli -m 0 --command="AT+QGPS=1,30,50,0,5"

I tried it on a device locally and get the same error.

root@571a43b:~# mmcli -m 0 --command="AT+QGPS=1,30,50,0,5"
error: command failed: 'GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Method Command is not implemented on interface org.freedesktop.ModemManager1.Modem'

Our OS team is looking into this and will get back soon. We might have an issue with patches done to mmcli recently, if our internal discussion is correct.

Thanks for reporting this, and will keep you posted!

#92

Hey @naga, we checked it further, and came to the realization, that the error of this command:

root@571a43b:~# mmcli -m 0 --command="ATI"
error: command failed: 'GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Method Command is not implemented on interface org.freedesktop.ModemManager1.Modem'

is very likely due to not having a SIM card available for the modem. It seems that mmcli cannot do much with modems that have no SIM card inserted.

Once a SIM card is inserted and the device power cycled, on my test device the response becomes:

root@571a43b:~# mmcli -m 0 --command="ATI"
response: 'Quectel
EC25
Revision: EC25EFAR06A03M4G'

Then the original application works properly, just have to way about 5-10 minutes for a fix. For example I get something like:

16.05.19 12:57:11 (+0100)  main  Using autodetected GPS device: /dev/EC25.NMEA
16.05.19 12:57:17 (+0100)  main  Error enabling GPS:  [ 'No such interface \'org.freedesktop.ModemManager1.Modem\' on object at path /org/freedesktop/ModemManager1/Modem/0' ]
16.05.19 12:57:17 (+0100)  main  Sleeping before restarting exited service
16.05.19 12:57:33 (+0100)  main  
16.05.19 13:07:33 (+0100)  main  Setting API Location -- Lat :  51.530003533333335  Lon :  -0.0611927
...

The error message in the output could have better communication, but actually, it is as it should be, and the code internally retries as it should, and appears to be working.

Thus:

  • do you use a SIM card?
  • if not, can you insert one, power cycle, and see how things work afterwards?
#95

@imrehg I removed the sim and EC25 from the Fin. Setup the board again. I see the GPS now.

Note: When i reported the issue I do have a sim card with access to the internet. The issue was that i couldnt access the location.

It works now. Thanks for all the support.