Gpio-ir-tx dtoverlay

I have an application which controls my AC unit using lirc
It was working fine until I upgraded to balenaOS 2.43.0+rev1
After some investigation, it looks like never kernels 4.19.X don’t have lirc-rpi modules
They got replaced by gpio-ir for receiving IR and gpio-ir-tx for sending IR.

I tried setting RESIN_HOST_CONFIG_dtoverlay=gpio-ir-tx,gpio_pin=26, but no dev/lirc0 device appeared.

It looks like gpio-ir-tx is not even in the list of overlays:

Am I missing something?
Any tips on how I can send IR commands with my Rpi now?



Thank you for the detailed investigation. I’m sorry that this causes problems. I’m not sure why it was removed, I guess it was not removed on purpose. You could however use to build any driver you need out of tree for your kernel. So this should always work to get the drivers that you need.
Let us know if this solves your problem.


@ Leonti, Did you solved this issue using the new Kernel?

lirc-rpi was removed in favour of gpio-ir. So you should use this new overlay from now on.