Getting Started - Deploy Code Step

raspberrypi3
#1

I’m doing the “Getting Started” walkthrough and all has worked flawlessly, but now I’m at the ‘Deploy Code’ step and running the git clone command from the Macintosh terminal returns a “-bash: $: command not found” message.

    • From the Mac Terminal how/what/where should the terminal be connected.
    • Once cloned, where is the file located and once located where is the file being located.

This step is not clear and I know I’ve missed something simple, but I can’t see where.

Thank you

#4

This is a reply to my own post, which after further reflection I’ve successfully resolved. Rather than delete the post, I leave it to help others and perhaps the Balena Engineers will consider revising the exercise. Also some of the pages need some updates.

I’ve successfully completed the “Getting Started” walkthrough. The only problem was Git was not installed on my iMac. However, for us Noobies figuring out what goes where is a learning snag. This is really a neat system and I’m looking forward to exploring the possibilities.

The installation is non-intuitive, but after a bit of research I found this resource on Git:
https://gist.github.com/derhuerst/1b15ff4652a867391f03

The author covers Mac/PC/Linux installations. I used the Mac install. The install did load some xcode tools, which was not explained in the directions. I just allowed the system to continue the xcode install. but once that was completed the rest of the “Getting Started” worked according to the exercise directions.

1 Like
#5

@richbpark thanks for following up and for letting us know your experiences! It may interest you to learn that we have a new(ish) feature called balena push that means you can circumvent the SSH key and Git process. If you take a look at one of our guides on the blog, such as balenaSense, you’ll see how this works. Eventually the getting started guides will be updated to include this too.