Failed to download image registry2

I’m trying to run the Get started with Raspberry Pi 3 and Node.js example app. I’ve tried both a Pi 2 and a Pi 3 B+. I’ve also tried using both wifi and just a network connection. Same error every time. Tried pinging Google and got no lost packets. Also tried running the commands in this post. It didn’t help.

I get this error:

Failed to download image due to failed to register layer: mkdir /var/lib/docker/aufs/mnt/xxxxxx read-only file system

Any ideas what might be going on?


I have a second application (built from) that I created a few days ago and has one connected device. The device is getting updates when I push new releases. But when I tried to add a second NEW device it fails with the same error as before. Something has changed in the last couple of days. ???

@dreed47 could you provide me with the dashboard link for this device and enable support access please?

Most parts of the operating system are indeed read only, but the docker directory certainly shouldn’t be (otherwise we would see issues like the above).

thanks for your help

@dreed47 I accessed your device, and can confirm that the /mnt/data filesystem was mounted read only. I was about to check system logs but your device went offline. Could you check that it is still accessible please?

it rebooted for some reason. it should be coming back online very soon

OK, so the device rebooted, and the data directory was mounted as read-write, as it should be. The device then started to download the image, and the directory was remounted as read-only. Unfortunately dmesg is returning no logs, which is something I’ve personally never seen. I’ll continue to look into the device and try to keep you updated.

thank you very much!

@dreed47 that was possibly the most confusing device issue I’ve ever seen!

The symptoms of the system logs being missing seems to come from massive SD card corruption. The SD card corruption, and the device rebooting seem to be because of an undervoltage that was detected by the kernel (I managed to get some kernel logs just after a reboot).

I would check that the power supply you’re using can definitely supply enough power for the raspberry pi.

Please let us know if you encounter any other issues!

Thanks for digging into this for me!

I tried several more times using several different power supplies, one rated 5V .5A and a couple rated 5.4V 3A and it still gets the same error. I also tried several different SD cards to make sure that wasn’t my problem.

What other things can I try?

I tried a different brand of SD card and it WORKED! I was using SP (Silicon Power) 32gb cards before. I tried 3 different SP cards and all failed with the same error. The one that worked was a no-name brand 8gb card.

Hi, our usual recommendation is Sandisk Extreme Pro, we never had a problem with that.

Also would recommend checking out your power supply. The .5A is definitely not good enough. The second one seems like the 5.4V might be a bit high, but not sure about what effect that would have.
If possible, for example to use the official power supply, we’d recommend that (that is rated +5.1V/2.5A).

Glad you got it working in the meantime.

Sorry, I meant 2.5A and not .5A … Thanks for your help!

Ah, makes sense, thanks for the clarification :slight_smile: