Failed to download image error

I am trying to run balenaSound 64-bit on a Rpi3B. The 32 bit version ran fine, but it was a bit slow, so I thought running a 64-bit version may help with that and since there is an option for a 64 bit OS why not give it a try.

I am booting from an SSD via USB3, in case that makes any difference (again the 32-bit version ran just fine).

I am getting the following error message on all of the images that are being downloaded.

failed to download image '' due to '(HTTP code 404) no such image - no such image: No such image: '

I found a post from lucianbuzzo that said to login on to a console and run a few commands. Well I tried that and the first command failed miserably

  • balena run --privileged --name parted -dit debian

When I run it I get

balena: failed to register layer: Error processing tar file(exit status 1): write /var/lib/dpkg/info/libsystemd0:arm64.shlibs: no space left on device.

Any help will be greatly appreciated.

Do you have a link to the post that outlines the commands you were trying to run? That command implies it’s a space issue? Can you check with df how much free space you have on your disk?

I cannot find it for the life of me (I’ll have to go through the browser’s history to see if I can find it that way). In any case I surely hope it is not a space issue since I am using a 120GB SSD and I used the same disk for the 32-bit version and it ran fine. But in any case the result of df -h is:

Filesystem                         Size  Used Avail Use% Mounted on
devtmpfs                           350M     0  350M   0% /dev
/dev/disk/by-partuuid/8f70a2f6-02  300M  278M  1.9M 100% /mnt/sysroot/active
/dev/disk/by-label/resin-state      19M  224K   17M   2% /mnt/state
none                               300M  278M  1.9M 100% /
tmpfs                              484M   64K  484M   1% /dev/shm
tmpfs                              484M  8.9M  475M   2% /run
tmpfs                              484M     0  484M   0% /sys/fs/cgroup
tmpfs                              484M     0  484M   0% /tmp
tmpfs                              484M   76K  484M   1% /var/volatile
/dev/sda1                           40M  8.0M   32M  21% /mnt/boot
/dev/sda6                          189M  184M     0 100% /mnt/data

Is there a way to manually download the needed services?

Hm it appears that your /mnt/data partition, where the update will be pulled into, is indeed full.

To get the right idea, what are you trying to do here? You flashed the raspberrypi3-64 image onto you SSD and are now pulling an update?

correct. nothing fancy.

1. flash drive
2. connect drive to pi and boot
3. wait about 2 minutes for pi to show up in the application console
4. errors start

I left the poor critter running all night to see, and when I woke up this morning found out that one of the services was running ‘snapcast-client’

Hi. When you first boot after flashing, balenaOS should expand the /mnt/data partition to fill the disk and this is not happening here. I’ve asked about this internally, but what is probably happening is that this specific setup (USB SSD) is confusing the expander. We’ll update you once we have a better idea of what might be happening here.

In the meantime, please use the 32-bit version. 64-bit applications are larger in terms of disk space and it seems that in this case the difference is big enough to push past the limits of the (unexpanded) /mnt/data.

Also, 64-bits balenaSound on the rpi3 is not recommended. See: