Failed to allocate manager object, freezing

I’m on my 20th or so commit to my Dockerfile. Had been working fine until now, I get the following:

The output from git push resin master is fine, same normal output.

I’ve tried pressing the reboot button from the UI. Same thing. Also tried a rebuild by making a new commit.

Pretty lost on how to proceed. Any suggestions are appreciated.

My first question to start this troubleshooting: What is the common way to revert to an older container image? I’m thinking make a branch at master’s HEAD, then reset the remote’s master back to where I want? What do you do here?

Found the easy answer to my first question, how to rebuild an older Dockerfile. Just checkout the old Dockerfile, commit it, and push it! If more than the Dockerfile needs to be reverted, I just reset my local master and did push -f, knowing that nobody would be affected.

And… it works. Now finding that bad commit.

I found the bad commit. The following line causes the output shown in the screenshot above.

RUN apt-get install libudev-dev

Help would be great.
But what I’ll do for now is COPY a compiled binary of what I’m trying to compile on target Beaglebone.

Hi! Yes, you can always force push a commit to the application (git push --force resin ...), and that can be a revert just as you mentioned, or even switching to code completely. In general, if you know which commit you want to revert, you can also use git revert and then just push normally (not rewriting the history), see some more info in these tutorials. :wrench:

Regarding the “freeze”, that line on its own does not break things, since you are using the -dev version of the package, are you compiling something in your code? Would it be possible to share your code with us, so we can look at the context? Or at least some more information on what are you doing? What hardware are you using?