Etcher Pro Latest Version Update

The current version on my Etcher Pro is 1.5.122 and the latest Etcher version is 1.7.9. How do I update the Etcher Pro to use the latest version?

I have raised your query with concerned team to check on whats the best way to update EtcherPro with the latest.


I wanted to share an update on the EtcherPro version update:

EtcherPro run via the EtcherPro-Fleet - GitHub - balena-io-hardware/EtcherPro-Fleet: balenaEtcher on EtcherPro hardware. If you check the repo we have the latest EP-etcher version at 1.5.122 currently. The team would release the latest Etcher once tested with the device; you should receive the update automatically once pushed from our end.

Is there some specific fix you were looking for which was addressed in v1.7.9? Also, let us know if you have any follow-up query.


I just thought that maybe an updated version would help with my current flashing problem noted in this forum post Issues Flashing or Cloning to SD Card - #2 by james-cws

Have you tried flashing with an updated version?

Flashing with the latest v1.7.9 version on the windows computer has no issues. We only have issues trying to flash with the etcher pro at v1.5.122

Hi there, I’ve contacted the etcher pro team to bring this to their attention. As v1.5.122 is running as part of the master release on the etcher pro balena application, and should be running on all etcher pros - imo it shouldn’t be this unstable. We should try to determine what else cold potentially be causing this.

In order to give the team as much context as possible, I’ll just ask a couple of more questions:

  • Can you use the “flash from URL” function successfully? This should flash your SD cards using an image pulled from balena cloud. I’d be interested to see if this works as it looks like the error is at the “source” end from the screenshot you posted on the forums
  • Have you seen these errors with multiple .img files - for example, does a “blank” balena OS image cause these errors?
  • The screenshot you posted - is that same error occuring in all 3 scenarios you noted - or just for "USB source - SD card target - .xz file? If it is just for that scenario, what error messages are you getting with the other 2?
  • When failing to flash an SD card properly (“files being copied poorly”) - is this happening to the SD cards in every slot on the EP? OR could the problem potentially be isolated to a single slot?
  1. Flash from URL
  • Flashing with a url did allow us to use the .xz file. It passed flashing and verification of 3 out of 4 SD cards on variable slots but none of them work with our system. They all display mdadm: no arrays found in config file or automatically. Gave up waiting for root file system. On the last failed SD card it displayed a source and destination checksum mismatch. We are not even using mdadm in our software.
  1. Multiple .img files
  • We have not tried multiple .img files. The errors mainly come after the flashing process when the SD card doesn’t work with out system, but we don’t see any of these issues when flashing through the Etcher on our Windows computers.
  1. Same Error
  • The same error does not apply to all the scenarios. It only applies when using our main .xz file that works on the computer. The cloning process gives us a bunch of errors on our Linux check process such as error: failure writing sector 0xfed008 to hd0 and putting it into emergency mode. The .img file either ends up being blank or fails during flashing with the warning that isn’t able to access certain drives.
  1. Multiple slots
  • I don’t know if this helps but the source file can only be selected from the left most inserted drive. Flashing the SD card in the other slots appear to yield the same results, regardless if it is one or multiple flashes at a time.

Hi there, thanks for responding - we chatted with the etcher pro team and we want to help to determine if this is a problem with the hardware, or a problem with the software, or something not working with the image.

  1. Could you please try to flash a balena os image for your device type, uncompressed, and report if it works (both the device boots, and no errors from the etcher pro). This will help us determine if there is a hardware problem. Could you try this from the URL, and from a drive.
  2. Has this etcher pro unit ever successfully flashed your image, to the point that there were no errors reported, and the target device managed to boot from it
  3. From your original post, I understood that you have tried multiple source drives, both USB and SD, and have always had the same result, is this correct
  1. When flashing our uncompressed file from a USB drive, the flash passes without error but doesn’t boot properly. The same happens with the compressed URL. When flashing our uncompressed URL file, the flash takes a considerable amount of time and still returns mdadm: no arrays found in config file or automatically during the boot process.
  • Note that we have tried flashing a standard Ubuntu image from Get Ubuntu Server | Download | Ubuntu through a USB and the flash passed and boots properly, so now we are thinking there is something weird going on with the Etcher Pro and our image specifically since everything works with the Windows PC.
  1. The etcher pro does flash the image “successfully” in terms that there are no errors but our device doesn’t boot properly. The boot process is always what fails when using the etcher pro with our custom image.

  2. We have used both a USB and SD as a source drive using the same img file but the result is the same in terms of our device doesn’t boot properly after flashing. Using both USB and SD as a source drive using the same .xz file results in the i/o read error from the original post.

Hi there, this information is great to know.

As you say, it seems like we potentially have some sort of issue with your .xz image and the etcher pro. What I recommend next is the following:

  • what is the device that you are trying to boot with the sd cards flashed with etcher pro? If its hardware we also have, would it be possible for you to provide us with your .xz file and we can try to reproduce the problem?
  • We can also try to flash a .xz image and boot it on a device (rpi4) - to see if this might be something common to etcher pro and .xz images
  • The ubuntu image that you did flash + boot successfully - was it compressed .xz?
  • We are targeting Intel x86_64 machines. Our image is a modified Ubuntu 20 LTS raw drive clone, compressed with xz. We would prefer to not share our image since it contains some proprietary data. But we could make a modified version to send to you if completely necessary.
  • Yes, could you please try flashing an rpi with a .img.xz from the etcher pro?
  • The Ubuntu image we tried is their standard ISO9660 bootloader. We cannot format our image with ISO9660 due to file constraints.

Thank you for the responses. While we work through them, can you please provide more detail on how you produce the raw drive clone? For example, do you run hardware from the drive before cloning it? Can you describe that process?

Yes, we boot to hardware before cloning. To create our image, we boot on a sample machine, set everything up, then run a wipe script before powering off. This wipe script removes the machine ID, accounts for drive uuids, and clears other data. This image is copied to other SD cards, and then we configure various services when booting a drive for the first time.
Again, this process works great using the standard desktop Balena Etcher software (as well as a direct dd), just not the dedicated Etcher Pro hardware.

Any updates on this issue?

Can we please get an update on the situation? Where are we at, do we need to provide more information, are you looking through this still?


Can you try something please? If you use etcher version 1.5.122 on your desktop, do you get the same error? Release v1.5.122 · balena-io/etcher · GitHub

I used etcher version 1.5.122 on my desktop and I had no issues. All of our issues still relate to the etcher pro.

Hi again,

This is very odd indeed. I just flashed the standard TLS ubuntu image (.img.xz) to a microSD card using EtcherPro, the RPi booted into ubuntu desktop without issues. Would you be able to send us an image that you modified? You can remove any proprietary information, just as long as it’s causing the same issues on your device.

Our image targets an intel x86_64 panel pc. Do you have a comparable system you can test against?

In the mean time I’ll put together an image.