Etcher error message "Cannot read property 'message' of null"

After validating a flashed ZORIN image, etcher completed with this verbatum message.
“Cannot read property ‘message’ of null” twice after successive flash attempts.

I dowloaded the image with firefox as suggested by the zorin website.

I was using Ubuntu on my laptop because I couldnt get Etcher to run successfully on my PC.

Hello, I’ve got exactly the same error also with Zorin OS (Zorin OS 16 Lite)
Did you solve the problem? If yes, I would like, if you can share your solution with me
Greetings Nando

Hi, I’ve got the same error with Zorin OS (Zorin OS 16 Core). If anyone has a solution, do reply.
Thanks, Pramod

Hi, we really appreciate everyone letting us know this is a recurring problem, we don’t have a solve yet but I wanted to let you all know that the issue has been raised internally as well as this GitHub issue and we are working on it.

It is not at all specific to flashing Zorin OS.

Today I have exactly the same problem and the same “message of null” when I try flashing ubuntuxxx.iso or linuxmintxxx.iso to two different new USB keys.
(theubuntu iso file had been tested and used OK before on DVD with “brasero” as a burner)

Here is what can be read on Etcher Console:
Wed Dec 15 2021 19:31:49 GMT+0100 (heure normale d’Europe centrale) Write failed ({“image”:{“size”:2143289344,“name”:“linuxmint-20.2-mate-64bit.iso”,“hasMBR”:true,“partitions”:[{“offset”:315392,“size”:4063232,“type”:239,“index”:1}],“extension”:“iso”,“path”:"/home/yves/System_Images/Linux-Mint/linuxmint-20.2-mate-64bit.iso"},“drives”:[{“size”:7801405440,“isVirtual”:false,“enumerator”:“lsblk:json”,“logicalBlockSize”:512,“raw”:"/dev/sdh",“error”:null,“isReadOnly”:false,“displayName”:"/dev/sdh",“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"/dev/sdh",“busVersion”:null,“isSystem”:false,“busType”:“USB”,“isCard”:null,“isUSB”:true,“devicePath”:"/dev/disk/by-path/pci-0000:00:14.0-usb-0:2:1.0-scsi-0:0:0:0",“mountpoints”:,“description”:“Linux Mint 20.2 MATE 64-bit Innostor Innostor”,“isUAS”:null,“partitionTableType”:“mbr”}],“driveCount”:1,“uuid”:“fac5066e-dad8-4256-a4b5-3123ca9c8c68”,“status”:“failed”,“flashInstanceUuid”:“fac5066e-dad8-4256-a4b5-3123ca9c8c68”,“error”:{},“sample”:0.1,“applicationSessionUuid”:“28d950d1-53a3-4d80-825a-9de0da53d826”,“flashingWorkflowUuid”:“d8712459-508a-413b-a088-8233cdf3b13f”})
gui.js:46 {“stack”:“TypeError: Cannot read property ‘message’ of null\n at file:///tmp/.mount_balenajW5sCY/resources/app/generated/gui.js:351:4728\n at async withTmpFile (file:///tmp/.mount_balenajW5sCY/resources/app/generated/gui.js:1:344288)\n at async elevateCommand (file:///tmp/.mount_balenajW5sCY/resources/app/generated/gui.js:351:4236)\n at async Server. (file:///tmp/.mount_balenajW5sCY/resources/app/generated/gui.js:351:8340)”,“message”:“Cannot read property ‘message’ of null”,“image”:“linuxmint-20.2-mate-64bit.iso”}

Regards


i launched balencaetcher v1.7.1 to flash a 32GB usb drive with linux mint 20.2 cinnamon.iso on my manjaro XFCE laptop (thinkpad x131e) from the XFCE program menu in the lower left , it kept failing with error null unable to read target after flashing and going to verifying, tried 3 times, then i had a thought why not run balencea-etcher-electron in terminal, it failed once again then i tried it with sudo balenca-etcher-electron thinking it was some kind of permission issue (unable to read target) and it flashed the iso successfully and verified successfully. But sudo shouldnt have to be used but it did get me a working USB drive to recover another pc in the house to a working state.

EDIT: spoke too soon, the live USB did not work. it did load the menu to select different options to boot live image or install but any of the options doesnt work or give errors.