Etcher 1.3.1 fails to start

Hi! I need some help. On my laptop with elementary Os (Loki) etcher refuses to start.
Downloaded the appimage etcher-1.3.1-x86_64.AppImage made it executable with chmod 755 and started via terminal. The output is down below.

jan@jans:/opt/etcher$ ./etcher-1.3.1-x86_64.AppImage
2521 2500
/tmp/.mount_T7P5sM/usr/bin/etcher-electron: error while loading shared libraries: cannot open shared object file: No such file or directory

You’ll need to install libgconf-2-4 as that’s a dependency on Linux with AppImages at this time; We still need to ensure it’s bundled in the AppImage at build time (see

I have libgconf-2-4 installed so it can’t be that.
Changing the owner from my user to root:root solved the problem. It seems a bit cumbersome to have to change owner but it fixes the problem.

@buskjan changing the owner of the AppImage? If so, could you have run it with sudo instead of owner change? Since Etcher would need sudo access later anyways.

By the way, on the Linux distro I use, files/software installed in /opt/ are usually with the root owner anyways, just checked my Etcher and it’s like that too.

I did not try with sudo since i can’t do sudo from the program menu but now I changed back ownership to me and it starts with sudo. I have got’n in to a bad habit it seems. To keep track of what is manually installed or compiled by me I change owner of these sub directories in /opt. Never had any problems with that until now. I won’t do that anymore :slight_smile:.

After changing back ownership of the directory and image to root everything works.
I get the following output: ./etcher/etcher-1.3.1-x86_64.AppImage
1755 1721
Gtk-Message: Failed to load module “pantheon-filechooser-module”
which I guess is because I’m en Elementary Os

Everything works fine so I will just ignore that.

1 Like

jhermsmeier[ team] [Apr 4] You’ll need to install libgconf-2-4

Thanks. Just installed etcher-electron-1.4.4-x86_64.AppImage on xubuntu 18.04 and got the error “Couldn’t find any package by glob '”. I tried searching for but with no success. However, searching for libgconf-2 showed up “libgconf-2-4” which I installed. Etcher working fine now.