Disable vc4-kms-v3d for raspberry pi 4

Hello
I have a problem with disabling dtoverlay vc4-kms-v3d
Any setting causes that this dtoverlay still appears on rpi4

I have to disable it, cause it disallow me to use particular monitors


This is not working

Empty is not working:
08.06.20 11:49:39 (+0200) Applied boot config: {“hdmi_force_hotplug”:“1”,“disable_overscan”:“1”,“framebuffer_height”:“780”,“framebuffer_width”:“1280”,“gpu_mem”:“396”,“arm_64bit”:“1”,“avoid_warnings”:“1”,“disable_splash”:“1”,“dtparam”:[“i2c_arm=on”,“spi=on”,“audio=on”],“dtoverlay”:[“vc4-fkms-v3d”]}

Test:


Should i raise an issue somewhere?

Hello, this overlay will be added on raspberrypi 4 by the supervisor: https://github.com/balena-io/balena-supervisor/blob/de80aacc2f15e9cf290af9798c22cf00634889bb/src/device-config.ts#L593-L594

Why? It’s not required for rpi4 and sometimes is breaker for usabilities
I think that for rpi4-64 only RESIN_HOST_CONFIG_arm_64bit should be enabled

I see that it’s related to https://github.com/balena-io/balena-supervisor/issues/1171
But definitely there should be option to disable this overlay.
It’s not even related to 64 bit rpi version, but the graphics

vc4-fkms-v3d is disabled very often - causes black screen and no hdmi output in some situations

I just raised an issue here:

Thanks for creating the issue, I’ve contacted the team about it. We’ll keep you posted.

Thank you very much