device stuck in rebooting process

I tried to reboot a device, but it looks like it is frozen now. I can access the device via SSH so it’s online, but can’t stop or start my service. Also rebooting or restarting seams to not have any impacts.

I granted support access for 1 week for this device: balena dashboard

1 Like


Some system logs show that it might be related to the environment variable you’re using, although that’s a bit weird.

Feb 18 13:55:21 40fdf50 90016a4c6054[1432]: [debug]   Replacing container for ... because of config changes:
Feb 18 13:55:21 40fdf50 90016a4c6054[1432]: [debug]     Non-array fields:  {"added":{"environment":{"VERBOSE_MODE":"True"}},"deleted":{},"updated":{"image":"sha256:..."}}

Could you try, as part of the debugging process, to temporarily remove the environment variable you have to see if it changes anything?

Ciao @pranasziaukas - Thanks for looking at my problem. I removed the ENV-Variable. Still the same as before

Thanks for the cooperation Immanuel.

The environment variable is no longer there but, as you observed, the issue remains.

There is one additional warning amongst the system logs, namely

Feb 18 13:55:21 40fdf50 90016a4c6054[1432]: [warn]    Ignoring unsupported or unknown compose fields: containerName

and container_name is known to be an unsupported field - docker-compose.yml fields - Balena Documentation
Could you please review the usage of container_name (and containerName) in your docker-compose.yml and Dockerfile?

container_name is not used and could be removed, thanks for mention this. but all other devices are running smoothly with the same docker-file, so it shouldn’t have to be this. I saw that the device is running again, but I did not change anything since removing the ENV-Variable (which isn’t a problem on other devices), so it’s solved but I don’t know why or how - anyway, thanks for your time and having a look at it, highly appreciated :pray:

1 Like

Happy to hear it now works for you @immi!

1 Like