Service start loop on Raspberry pi zero

Hi everyone!

I am working on my balena-nsd project for raspberry pi zero.

I got it working. However, after rebooting the device, I have got an infinite service start loop.

Host OS version: balenaOS 2.46.1+rev1 (development)
Supervisor version: 10.6.27

I even tried to reflash and balena-push my project again but still have the same issue:

I have no clue where to start troubleshooting process.
Please help. Any ideas are appreciated.

Thank you!

found the hint here:

When I ran:

journalctl --no-pager -u resin-supervisor

I found the following recurring error, which has told me that the IP address in docker-compose under service.ports was incorrect:

Mar 22 14:49:57 5aa8eda resin-supervisor[1330]: [error]   Device state apply error Error: Failed to apply state transition steps. (HTTP code 500) server error - driver failed programming external connectivity on endpoint nsd_2085783_1308655 (72b0172b432d565d188842d323260ce857121ddbd2286a2baa1317c4219f05e3): Error starting userland proxy: listen tcp bind: cannot assign requested address  Steps:["start"]

Leaving this here just for a reference… Hope it will help someone.

Hey Drew, glad you could figure it out, and thanks for coming back to leave a reference for others. Let us know if you get stuck again. Have a nice day!