Device offline with green LED repeatedly flashing 4 times

Our Raspberry Pi 3 became disconnected from and was completely inaccessible. When we got physical access to the device the red power light was constantly illuminated and the green light was flashing 4 times in a row. We are running Resin OS 2.12.5+rev2 so are on a fairly recent operating system.

Having looked at the Raspberry Pi troubleshooting pages I found that on the original Raspberry Pi bootloader this means that start.elf was not launched. Power cycling the device solved the issue so I don’t this was caused by a corrupted SD card.

What would be the best steps to debug this issue? Are there device level logs available that the root cause of the crash could be identified? I hope someone has solved a similar issue or knows where is a good place to start investigating the problem.

Hi. At this point there’s not much to see.
For the future, you can enable persistent logging so that upon reboot you should be able to inspect the logs (they are allowed to only 8 megabytes of logs currently):