CM4 / stucked in 'Initializing device'


I have been using Etcher for a while to flash a lot of CM4 boards (> 1000 units) - however the recent batch of cm4 boards I received cannot be flashed as-is because Etcher is stucked in “Initializing device” state.

I’m using the latest release of etcher (1.7.9) and I have the same behavior on both MacOS and Linux.
The boards can be properly ‘mounted’ with rpiboot launch manually. (which is a workaround before using Etcher)

After further investigation, it seems that the boot loader included with Etcher (and more precisely the one bundled with the node-raspberrypi-usbboot node module) is outdated.

I’ve since tried to build Etcher from the sources and replaced the bootloader (bootcode.bin / start4.elf) by the most recent version coming from the rpiboot repository, and it’s now working fine.

I have the exact same problem with my Balena Etcher Pro (v1.5.122), which makes it completely unusable while it’s not fixed.

Am I the only one with this issue ? Any plan to update that and integrate this ‘fix’ to a new release ?

Many thanks in advance

Yes, this is a known issue with the most recent batch of CM4, and your workaround is right on the money. A fix is coming and we may have more to share shortly.

Hi hraftery,

Do you have some news about the fix ?
I 'm in the same situation as Leon671…
tell me more please !

Hello @Joseph1 and @Leon671 we have a Github issue opened here → New Pi Compute Modules Not Initializing · Issue #3792 · balena-io/etcher · GitHub

You can follow the solution from there. Anyway we linked internally the github issue with this message, so once the issue gets closed we will update you.

I ran into this issue today as well… spent all morning thinking i borked my cm4 somehow, I went back to version 1.7.2 and the problem disappeared and I had no issues flashing.


Thanks for the confirmation @dslfreak

The changes between 1.7.2 and 1.7.9 does not explain why did it work.

As mentioned earlier the bootcode files are the same outdated one in that release.
Could it be that the device was booted by rpiboot or even on other computer, then etcher 1.7.2 opened and observed as working?

Version 1.13.3 has improved the mounting of CM4 as mentioned in the github issue.