Chromium on Raspberry Pi 1

I’m having the hardest time getting chromium to run on my Raspberry Pi 1. I found this project (GitHub - TechHub/ RPi client code to spawn a browser and show the community messages on the display, using but had to make a few modifications, including:

  • Update the dockerfile to include the xserver-xorg package.
  • Switch chromium references in xinitrc to chromium-browser

It looks like everything is installed, but whenever I try to launch chromium, I receive the error:

/usr/lib/chromium-browser/chromium-browser: symbol lookup error: /usr/lib/chromium-browser/chromium-browser: undefined symbol: mmal_vc_init_fd

Googling around shows this error could be caused if the kernel needs to be updated - [reference]((Setup: Boot to Browser (Jessie Full) · BillyBlaze/OctoPrint-TouchUI Wiki · GitHub)

I tried to install older versions of chromium but couldn’t get anything installed. apt-cache madison chromium-browser shows only a single version:

chromium-browser | 51.0.2704.91-0ubuntu0. | Index of /debian jessie/main armhf Packages

Any ideas on how I can run chromium with on my Raspberry Pi 1?

Yeah, armhf shows it’s for the hard-float version of the system, which is armv7 in general, RPi1 is armel (or armv6) usually (softt-float), if recall correctly. Would not recommend compiling from source, it’s an enourmous process since it’s a huge project. It would probably make a lot more sense to upgrade to a RPi3.

In we are doing quite a bit of backporting for older architectures, mostly the base software that resinOS requires, and there’s plenty of experience going around to not do backporting/recompilation unless there’s a very good reason to do so :slight_smile:

Sounds good to me. I’ll plan on upgrading to the RPi3. Thanks for your help!

1 Like

I’ve gone through the process of setting up a new app in resin and specifying Raspberry Pi 3 as my device type. Unfortunately I’m getting the exact same error after upgrading to a Pi3.

Could it be anything else?

Can you share your Dockerfile to take a look at? (Github link, or post it here?)

You can check out the dockerfile and corresponding bash scripts here -

I borrowed them from ( and made a few modificiations.

Hey @joelongstreet, I was checking it out, based on what other forums are saying, it might be that the kernel on the resinOS is too old for the latest package version of Chromium in the archives it pulls from. I’m basing this guess on point 7. here. Will be pinging @andrei, the Raspberry Pi board support package maintainer about updating it!

In the meantime, what are you trying to build?

I see that you are displaying a URL, and the current code does pretty much just that. Chrome + X is pretty complex to set up in general, if you want to go down on the “display websites” path, there’s also resin-electronjs, which was designed exactly for that by @curcuz. Would recommend to give that one a try.