Can't download image

I am new here and I can’t seem to actually download the image needed to put on the Rpi. I get “downlaod > Failed - Needs authorization” and if I used a DL Manager it asks for credentials… Mine don’t work.

I know it has to be something simple… but what???


Hey @Shadowed, I’ll take a look at debugging this for you if you could give me a bit more information about how you’re trying to download the image.

  1. Are you trying to use the dashboard via your browser or the CLI to download the image?
  2. If you’re using a browser open this site and post the link from so we can replicate your setup. If you’re trying the CLI let us know what OS (and version) as well as your node & npm versions (node --version && npm --version)
  3. What version of ResinOS are you trying to download and for which version of the Raspberry Pi? If you are using a dashboard a screenshot of the ‘Add a new device’ panel would be perfect.



Rpi Zero and tried 2/3… also tried production/development wifi/no wifi

Tried chrome, edge, and IE. Tried over VPN to bypass my firewall…

Thanks for coming back to me with the info! I have tried mirroring your setup and still can’t reproduce this. I can however reproduce something similar if I start blocking our cookies.

Could you try logging in to Resin in a Chrome incognito window and try the same thing? Also it would be worth creating and testing with a new profile to rule out any add ons or settings that may be interfering.

If that fails… are you familiar with the use of developer tools in Chrome? If you open the tools and view the Network panel whilst trying to download the OS you’ll be able to see all the requests to our systems. You’ll be able to see a status column, and look for any codes that read 401, or in fact anything beginning with a 4; if there’s anything there take a screenshot.

If this still isn’t working, please enable support access for your application and I’ll try your exact setup here.

Ok after playing around with that, I think it was the FDM extension that was mucking things up. Once I disabled it the download worked fine. Thank you very much!