cannot find jetson module


today, i tried to flash another one of my jetson modules with balena, but both the dashboard as balena scan cannot find the module.

i currently have a jetson-nano with emmc memory flashed and connected to the dashboard, while the new module is a jetson-nano-sd with an sd card.
i also flashed a jetson-nano-sd before (i deleted the device) and it worked fine.

image: ‘balena-cloud-demo-jetson-nano-2.56.0+rev1-dev-v11.14.0.img’
balena scan:

>>>root@jasper:/home/jasper/balena-cli# DEBUG=1 balena scan
[debug] original argv0="balena" argv=[/home/jasper/balena-cli/balena,/snapshot/versioned-source/bin/balena,scan] length=3
[debug] new argv=[/home/jasper/balena-cli/balena,/snapshot/versioned-source/bin/balena,scan] length=3
Scanning for local balenaOS devices... Reporting scan results
  host:          7c839ba.local # my emmc module
  osVariant:     development
    Containers:        3
    ContainersRunning: 3
    ContainersPaused:  0
    ContainersStopped: 0
    Images:            13
    Driver:            overlay2
    SystemTime:        2021-01-27T12:58:03.488627586Z
    KernelVersion:     4.9.140-l4t-r32.4.2
    OperatingSystem:   balenaOS 2.56.0+rev1
    Architecture:      aarch64
    Version:    19.03.13-dev
    ApiVersion: 1.40

Hi there,

if you can’t find your second nano using either the dashboard or a balena scan are you sure it has a working network connection? Can you find it using your router network tools? Possible causes could be no network connection, or failing to boot in general. Can I ask:

  • which model nano are you using? We support the A02 and B01 models, but our support for the Nano 2Gb is not yet released.
  • how did you flash your nano?


thanks for the quick response. i am using the 4Gb B01 module.

-arp scan -l results in no new devices when plugging in so it is not connected to the network.

-plugging the cable into my pc works just fine, so no failure in the network cable

-I inserted the sd card into another device with the same results

Hey @jap937, so how did you flash the SD card? Did you validate that flashing was successful? (balena Etcher offers this feature)

It’d be good to try out a different SD card (that you know functioning fine) to rule out SD card rooted issues.

Next, is it possible to connect the device to an external monitor?
As you are using a .dev image, you’d see the device printing logs. There could be a warning or error explaining the issue here.


i am flashing with balena etcher and currently attempting an older image version and different sd card (16Gb). There is no apparent difference.

The monitor shows the balena logo as usual.
i entered the terminal (ctrl+alt+F4) and when plugging in the network cable, i get the message “eth0: link up” and ifconfig shows no errors except for the lack of inet address.

i do consider the possibility that our network is acting weird

Perhaps you can rule out your network by adding another known working device and confirm it’s getting an IP address.

If you happen to have WiFi and a dongle, it would be interesting to test with that and see if you get connectivity.

Also, you can see if anything stands out using dmesg in the terminal, or dmesg | grep -i eth0

thanks for the help,
it seems to be a hardware specific as only one of my 3 devkits (same versions) seems to connect to the network
dmesg shows nothing relevant

You are most welcome. That explains the issue. Hope you could get refunds or replace these broken devices.