Building the JN30B-nano image from source


I tried to build the jn30b-nano image from source. Using the steps described by the balena-jeston repository.
It fails during the do_image_resinos_img step. Sadly i do not get any real information on why it fails through the logs. Does anyone have Ideas on what i should look into?

NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: resin-image-1.0-r0 do_image_resinos_img: Function failed: do_image_resinos_img (log file is located at /home/?/yocto/balena-jetson/build/tmp/work/jn30b_nano-poky-linux/resin-image/1.0-r0/temp/log.do_image_resinos_img.28812)

I will start a fresh build with the following configuration.

Build Configuration:
BB_VERSION           = "1.42.0"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "universal"
TARGET_SYS           = "aarch64-poky-linux"
MACHINE              = "jn30b-nano"
DISTRO               = "balena-os"
DISTRO_VERSION       = "2.45.1"
TUNE_FEATURES        = "aarch64 armv8a crc"
TARGET_FPU           = ""
meta-poky            = "HEAD:f2b442c5c8e3925a4d3fc9693f1e47863dade2a9"
meta-python          = "HEAD:6fa72d587aab8e9d56d67a2552eb9cfbe25c86d2"
meta-tegra           = "HEAD:9d1cac5c9647c5f56dc44b5de32f888ec4e9a511"
meta-balena-warrior  = "HEAD:0c90c7e890b724ba875afa80eac50e2a8a51aa58"
meta-balena-jetson   = "master:64ba978ad7a8a3dd842356b977c141217002c039"
meta-rust            = "HEAD:84710b341be53cc2af13ecc8ae87773cf84687bf"

There where just a few dependency conflicts. A fresh build solved the issue.

Good to hear you got this working. Let us know if you run into any more issues while building the OS

Just FYI, it might be cool to add a fresh build option into the barys script.

I might open an issue and PR tonight :slight_smile:

Hi Frederic, please do! :slight_smile:

I was just blind and could not finde the -r option for a clean build (aka. remove cached build)

It happens to the best of us : ) Good to hear you figured out the problem.