Builder unavailable


I’m having troubles pushing a new version. I keep getting a “Builder Unavailable”. Does anyone know what might cause it? It worked once when I followed the tutorial, but after adding a new line in the docker file to try and get it to build a new version I keep getting the following error.

chris@deb-jessie:~/simple-server-node$ git push resin master
Enter passphrase for key ‘/home/chris/.ssh/id_rsa’:
Counting objects: 35, done.
Compressing objects: 100% (34/34), done.
Writing objects: 100% (35/35), 376.69 KiB | 0 bytes/s, done.
Total 35 (delta 13), reused 0 (delta 0)

Error: Builder unavailable

remote: error: hook declined to update refs/heads/master
! [remote rejected] master -> master (hook declined)
error: failed to push some refs to ‘’


Hey @gurtlerc, what did you add to your Dockerfile? Error: Builder unavailable is likely an issue on our side, but your addition may help diagnose the issue.



Hi Craig,
It happened after I changed from using a facebook login to a username/password. I did that to use “resin sync”. Changing back to the facebook login account didn’t help. In the end I created a new user account and went through the sample again and it’s all good now.


Thanks, it sounds unrelated. Were the Error: Builder unavailable errors reproduce-able on every push with your old account or was it an interrmitant problem? I’ll let you know if when we find the root, but in the meantime please let us know if you run into it again.

Thanks for reporting!


Hi Craig, thanks yes on every push I had the same error. I’ll let you know if it happens again.