Beaglebone Green Wireless Bluetooth

I can’t seem to get Bluetooth working on the Beaglebone Green Wireless. I tried but get an error:

cp: cannot create regular file ‘/lib/firmware/ti-connectivity/TIInit_11.8.32.bts’: Read-only file system

Any ideas? I’m using ResinOS v2.2.0+rev1.

Hi @bradstewart, that project was for resinOS 1.x (will update the project description for that to avoid confusion!). On resinOS 2.x it would not work because of the read-only host OS. Should not need that firmware anymore, thus you can run a simpler setup.

You can try running this Have a discoverable bluetooth device nearby and then this code should have “Test passed” if it was discovered properly. Can restart the application from the dashboard to run it again. Then you can start modifying that source code for your application (or start from scratch, I think you just need bluez to work).

Thanks for quick response @imrehg.

While waiting for another device to update with that repo, I tried the following in the web terminal:

root@710951f:/usr/src/app# hcitool scan
Device is not available: No such device
root@710951f:/usr/src/app# hcitool dev

So not confident it will work.

I couldn’t seem to find the requisite setup script (bb-wl18xx-bluetooth) or firmware for the BBGW’s Bluetooth anywhere in the container (nor is the board’s Bluetooth LED on), which is what led me to try the resin-bbgw-bluetooth repo in the first place.

I’m fairly new to Docker, so maybe its not visible in my application container/I’m just looking in the wrong place?

And here’s the output from pushing test-bluetooth to a bbgw:

.08.17 18:40:49 (-0500) /sbin/udevd
30.08.17 18:40:52 (-0500) Testing bluetooth. Make sure you have a bluetooth device enabled and visible.
30.08.17 18:40:52 (-0500) Scan for devices...
30.08.17 18:40:52 (-0500) Device is not available: No such device
30.08.17 18:40:52 (-0500) Test finished. App configured to not exit.Restart the app if you want to retest.
30.08.17 18:40:52 (-0500) TEST FAILED

Hey @bradstewart, sorry, it’s my bad. Turns out that the latest resinOS does not ship with this required firmware. We have open issue for it, and can subscribe to that to see the updates, we’ll be fixing this up. In the meantime, a workaround is to use an external bluetooth dongle, probably.

There’s an issue open for this, where you can track progress or provide some feedback:

Sorry about the inconvenience!

Thanks for the update @imrehg. Will follow the progress on GitHub. Any idea when this might be implemented?

Sorry, no concrete timeline. We have discussed it and have team member is now looking into how’s the best to integrate this firmware, but this might take a little bit. Beaglebone is managing its firmware in a somewhat surprising way. :confused: We’d love to use that function too, for sure (there are a number of internal projects using different flavours of Beaglebone)

Understood. And yes, everything about the Beaglebone’s firmware is a bit strange.

1 Like

Created for fixing this

1 Like

Just tested this PR on BBGW, and seems to be working.

@bradstewart just wanted to let you know that this has now been released (resinOS 2.4.2), if you’d like to check it! Here’s the changelog for that release too.

Thanks Greg. I saw that last week, and its working great. Awesome to see it resolved so quickly!

Thanks a lot for the feedback, cheers! :slight_smile: Would be really happy to hear anything interesting you build!