Balenasound new install - no Wifi connection w/o ethernet

Just did an install of latest balenaos w balenasound on a PI4. Great stuff! Install went fine and I can connect to spotify and bluetooth. When I installed I did choose both ethernet and Wifi and provided my Wifi details. When I boot the device with ethernet connected - I get both Wifi and Ethernet. But if I boot the device without ethernet it will never come online :thinking: . I verified the Wifi credentials and SSID and they are correct. Is this the way it should behave or do I need to reinstall without ethernet or is it possible to disable ethernet through config?

Hi, have you tried to connect to the device through an ssh connection?

In that case you could see if the device is actually connected to the wifi with the Network Manager:

This command will show the network interfaces, if the device is actually connected to the wifi, you should see a ‘connected’ near your interface name ‘wlan0’ problably

nmcli device

for more information about the Network Manager check the documentation

While it is probably possible to disable the ethernet via a system-connection file in the boot partition, I don’t think this is required and you shouldn’t do it.

The Wifi should come up if it has credentials configured, and it sounds from your first message that it does when the ethernet is connected. Could I ask how you’re confirming that?

Thanks for the repies.
Really weird. Tried at least three times and it didn’t hook up to the wifi (without ethernet). Now it suddenly does… must be something on my wifi side.
Sorry to bother you guys. Now to the issue that some other have with low output volume - but that seems harder to fix. Thanks again.

NvInfere is needed by TensorRT, but both are not needed to run TensorFlow on the JetsonNano. If you want to optimize your NN to run fast on the JetsonNano these libraries might come in handy. Its up to you. Thanks

@iosman987 wrong thread?

thanks my issue has been fixed.