BalenaSound analog audio output vs. hdmi

Hallo, I just installed BalenaSound and noticed that the audio output goes through the RPi 3 B+ HDMI connection to the monitor speakers instead of to the analog audio jack. When rebooting without HDMI monitor, the audio output goes to the analog audio connector. Is there a setting that can force the audio output to the analog connector?

Best regards

Hey,
Have you tried custom configuration variable?

RESIN_HOST_CONFIG_hdmi_ignore_edid_audio = 1

in your image configuration panel in the portal?
hth,
Piotr

Hallo,
This parameter did indeed do the job, for which I thank you. In the tutorial there was an instruction to turn off the onboard audio in favor of a DAC (HAT) which is very desirable because the RPi 3 analog audio is of dubious quality.

I had searched but I couldn’t find the parameter you mentioned in this starter app and the Balena documentation online. Based on your example and some googling, I found a useful list to customize the RPi config.txt with several variables. A list of freely selectable customer variables that can be added like the one mentioned above can be found on https://elinux.org/RPiconfig

Best regards,

Glad to hear!

There is documentation for the topic I’ve used as reference:
https://www.balena.io/docs/reference/OS/advanced/#modifying-configtxt-remotely:

If your device has a supervisor version above 1.0.0, it has support for modifying the values in config.txt remotely using configuration variables.

hth!