Balena CLI - not compiling Screenly OSE

I have used Balena CLI before to compile new versions of Screenly OSE but it is no longer working.
The build log can be found attached. Am I doing something wrong?

Thanks in advance for your support.

[Info] Building on arm06
[Info] Pulling previous images for caching purposes…
[Success] Successfully pulled cache images
[Info] Starting to build redis
[Info] Starting to build srly-ose-server
[Info] Starting to build srly-ose-viewer
[Info] Starting to build srly-ose-websocket
[Info] Starting to build srly-ose-celery
[Info] Starting to build srly-ose-nginx
[Success] Successfully built service redis
[Success] Successfully built service srly-ose-nginx
[Success] Successfully built service srly-ose-viewer
[Info] Uploading images
[Success] Successfully uploaded images
[Error] Some services failed to build:
[Error] Service: srly-ose-server
[Error] Error: The command ‘/bin/sh -c pip install --no-cache-dir -r /tmp/requirements.txt’ returned a non-zero code: 1
[Error] Service: srly-ose-websocket
[Error] Error: The command ‘/bin/sh -c pip install --no-cache-dir -r /tmp/requirements.txt’ returned a non-zero code: 1
[Error] Service: srly-ose-celery
[Error] Error: The command ‘/bin/sh -c pip install --no-cache-dir -r /tmp/requirements.txt’ returned a non-zero code: 1
[Info] Built on arm06
[Error] Not deploying release.

Hi Luc, this is a known issue. Please see this thread for a workaround:

To help us prevent this experience in the future, can you please let us know:

  1. What device type and balenaOS version you’re using?
  2. And whether the workaround works for you?

Hey there, thanks for the fast reply. I had seen this issue, but it didn’t seem entirely the same as I have 3 failing services (server, websocket and celery) and the article mentions two (server and celery). I have however tried the suggested fix but it didn’t do any good for me.

Im using the most recent balena OS 64bit (balena-cloud-Cantina-raspberrypi4-64-2.101.7+rev2-v14.0.13.img) on raspberry pi 4B - 4GB.

I am however seeing this issue when trying to compile Screenly OSE through Balena CLI on my Windows laptop. Not sure if the Balena OS version has a role in this but if I need to change or try something else, I’m open for suggestions :slight_smile:

Hey all, have you perhaps had the chance to look into this? I would love to get it up and running by the end of the week. If not I will have to look for an alternative to Screenly OSE and that would mean extra work for switching the devices already up and running to that new solution as well.

Hi Luc,
I was reading though your last messages and some questions came to mind:

  • Did you update your balena-cli to the latest version? It is always a good practice,
  • You mention you are running on a Windows laptop, did your previous successful bulids also come from a windows machine? Case sensitivity is not supported by Windows filesystem and can trip you in multiple ways.
  • You can also check your Dockerfiles and see if the base images you are using are not outdated OS versions (I got this happening this morning here where the base image was an outdated Debian Stretch).

Let me know if any of it helps,


Hi Aurélien,

  • I have updated the balena-cli to the latest version before trying
  • I’m trying to build and push Screenly-OSE on the same laptop as I did before (was somewhere early last year)

As I was typing this message and was coming up to the third point, I noticed that the github page for Screenly-OSE was updated yesterday (GitHub - Screenly/screenly-ose: The most popular digital signage project on Github!). I have downloaded the project again and now I get the Unicorn after succesfully compiling / building.

The issue is solved with the new release and this issue can be closed. Thanks a lot for your time!

That’s great to know! Thanks for informing us what solution worked for you!