Balena on RaspberryPi 3. Lower Bluetooth connection Volume

I got Bluetooth sound working with the Hifiberry Amp+ using the variable of “hifiberry-dacplus” suggested by Toby. The Hifiberry Amp+ is a stand alone Amp Hat for the Raspberry Pi, and there is not a physical volume adjustment knob. The only current issue is that the Bluetooth connection sound is way louder than I’d like. Can it be lowered? It does not appear to be related to the volume of my phone/device connecting to the balena/RPi.

Hi @nlcarrii welcome to the forums! Are you using the balena sound project ( https://github.com/balena-io-projects/balena-sound ) ? If not could you please tell us a little more about your software and hardware setup?

Hi Lucian. Thanks for the reply. I am using the balena sound project. I learned about it when flashing a micro SD for something else using balena Etcher. This is something I’ve been looking for for a while!

I flashed a card and loaded it on an RPi3 B. I am setup on balena cloud and can Bluetooth to the RPi. It has a Hifiberry Amp+ amplifier (https://www.hifiberry.com/products/ampplus/). Connecting, disconnecting, and playing music work fine. The media/balena volume can also be controlled via my phone, which is nice. The issue I am seeing is that the tone that is played when the bluetooth connects and disconnects is extremely loud, it may be at max volume. I am hoping to lower it to maybe quarter volume or lower. It scared me and my wife the first time we heard it. Thanks Again.

Edit: I found this webpage and this SSH command if it helps:
https://blog.paddlefish.net/?p=895
amixer set PCM – 100%

Thanks for the feedback, I’ve opened an issue for this on the balena-sound project, and can follow any changes there too!

Thank You imrehg!

Just a note that balena-sound version 0.2.0 (changelog) was released, addressing issue 28 (Add volume configuration options). The README file explains:

Set output volumes
By default, balenaSound will set the output volume of your Raspberry Pi to 100% on the basis you can then control the volume upto the maximum from the connected bluetooth device. If you would like to override this, define the SYSTEM_OUTPUT_VOLUME environment variable.
Secondly, balenaSound will play connection/disconnection notification sounds at a volume of 75%. If this unsuitable, you can override this with the CONNECTION_NOTIFY_VOLUME environment variable.

Thank You pdcastro. I have tried to add these variables to my device with no luck. I have a screenshot below, please let me know if you see an error(s).

EDIT
I also may not be on version 0.2.0, but do not know where to check this.

EDIT
I went to try and update and since my balena is a development version, updating is not supported. I assume I need to re-flash my sdcard, and choose “production” instead of “development”?

@NLCarrII it sounds like you’re mixing up balenaOS updates and app updates. To update to the latest version of balenaSound you’ll pull the code from GitHub and push it to your application again (balena push). You don’t need to reflash anything, nor do you need to update balenaOS.

Secondly, the variables look good apart from the fact you have included the % symbol; this isn’t required. I will update the readme to make this more clear.

Thank You @chrisys. I updated the “%” part and will try the push tonight at home. I’ll update here with the results.

image

EDIT: Works here. Haven’t tested thoroughly, but it seems as though 15 is as low as it goes for me, in relation to the connect/disconnect sound. Not complaining though, as I am super happy this was addressed quickly and I am satisfied with the results.

1 Like

@NLCarrII that’s great to hear! Thanks for letting us know it worked :slight_smile: