Balena CLI push problem

Hi there, I try to use the Balena CLI to push the “Hello World!” file from Once I unzipped and ran the file through command, it shows the error : no “Dockerfile[.*]”, “docker-compose.yml” or “package.json” file
found in source folder “.”

Hello, Please could you confirm which directory you are in when you do balena push? (It should be the root directory of the hello world project)

yes, it’s in the root directory

Please could you ls in the directory you’re doing balena push from, to confirm that the Dockerfile.template is present?

(Or, dir if using windows cmd)

Yes, the balena-python-hello-world-master is presented in the root directory. I tried different root directories but it still shows error with no docker files

Could you please paste the command prompt you see? It sounds like you are one level above the root directory. You should be in the balena-python-hello-world-master directory. balena-python-hello-world-master should not show in the contents when doing ls/dir, but Dockerfile.template should.


Oh I solved it!! I put it the different location drive…

Thanks for you help!

A pleasure. Glad you solved it!