failed to push application to balena cloud

i’m using macbook air with parallel windows10. installed balena cli on windows10 and followed the instructions how to. even watched the recommended youtube video. when i finally try to push i get this error:
EPERM: operation not permitted, scandir ‘C:\Users\joergzimm\Anwendungsdaten’

i dont know what to do. is it because windows running on mac? i use parallel desktop software so i can run catalina and w10 simultaniously on this mac.

i even read here that it would help to install older version of cli and did. but still same error.

i try to use balena sound for my old hifi. i use a raspberry 4B 2GB.

Hi Joerg, welcome to the forums!

A few suggestions regarding your problem:

  1. Are you sure you are running balena push <app> from the correct directory? We’ve seen similar issues happen when users mistakenly run commands from the wrong path. You need to run the command from within your project folder (which usually contains either a Dockerfile, Dockerfile.template or docker-compose.yml file.

  2. If you are running from the correct path:

  • Can you share the exact command that is failing?
  • Can you re-run the command with DEBUG=1 prefixed and share the output? Example: DEBUG=1 balena push <your-app>

Finally, I’m mostly curious since the CLI should work fine on win10 even running with parallel, is there a specific reason you are running the CLI in this environment instead of Catalina?

In case you are running balenaSound for example, you would need to run all commands from the same directory where you have the project’s docker-compose.yml file.

hi, thanx for your prompt reply.

i installed it like the youtube video suggested on C:\

i dont find any docker file. what do you mean by projects folder? in the instruction is no mention of a projects folder:

i ran debug and got this result. I’m not really fluent in computer, so dont know what that means:

C:\Users\joergzimm>set DEBUG=1 balena push raspberryjoerg

C:\Users\joergzimm>balena push raspberryjoerg
[debug] original argv0=“balena” argv=[C:\balena-cli\balena.exe,C:\snapshot\volume\bin\balena,push,raspberryjoerg] length=4
[debug] Using . as build source

i use windows and not mac for this because i’m used to windows and mediamonkey for my music library.

Hi @Joerg, it looks like you are in the wrong directory when you are running the push command. In the instructions where it says “Download the project from GitHub”, how did you do this e.g. via downloading the zip file? If so you’d need to unzip it and then run the balena push command from that unzipped directory (that directory contains the required docker-compose.yml file)

yes, downloaded the zip file and unzipped it to drive c

i searched this directory for ‘docker’ and had no results. i even looked at all subdirectories by hand so to speak and couldnt find a docker-compose file in the unzipped directory balena-cli-v11.23.0-windows-x64-standalone

however, the balena-sound-master i downloaded but had no instructions where to unzip it contains a docker-compose file. but in the instructions is no mentioning of where to put it or what to do with it. only to download it. maybe thats the problem?

i therefor put the balena sound directory also in drive c
and created in system variables a path for both, balena-sound and -cli.

and although i’ve selected drive c as path the error says:
EPERM: operation not permitted, scandir ‘C:\Dokumente und Einstellungen’

why does it say: ‘C:\files and settings’ in its error message?

So the simplest solution is you need to run balena push from within the balena-sound-master folder that you downloaded and unzipped. Assuming you put this folder in C:\balena-sound-master in the command prompt change to this directory cd C:\balena-sound-master then when in that directory run the balena push <app> command. Alternatively, you can specify the location of this folder using the --source option e.g. balena push --source C:\balena-sound-master <app>. You don’t need to create any system variables.

that did the trick.
have a good night (or day). here its 10pm

1 Like