Balena-CLI hangs when using credentials ( v11.3.3 )

I was using balena-cli ( Version 10.10.x ) quite a while now on various systems (Linux & Windows). I am able to successfully login in to our openBalena instance with balena login & Credentials option.

However, I wanted to update balena-cli to the latest version ( v11.3.3 & v11.3.2 ) the terminal/console hangs after choosing Credentials in the login menu. It says to enter email first but it won’t react to input anymore.

After going back to 10.10.x it works again. Sadly there weren’t any error messages.

Is this something only I experienced ? How would I report this behaviour correctly ?

Hello, you should be able to get more output by prefixing the command with DEBUG=1. Can you please give it a go? I’ll try to reproduce later on myself as well, but might be something really obvious.

1 Like

So I set DEBUG=1 then again balena login (Credentials). After that it hangs again. Can’t input email nor kill the command. (Windows & Linux)

Only debug output : Debug: original argv0="balena" argv=[D:\NODE\balena-cli\balena.exe,C:\snapshot\resin-cli\bin\balena,login] length=3

Hi @turbopasi , I just tried this on macOS with cli 11.3.1 and the balenaCloud backend and it worked. Do you have a balenaCloud account to check if it fails in the same way for that backend, then we can narrow down what is causing it.

1 Like

I do not have a balenaCloud account for now. What I just tried is to use balena login --credentials (with the credentials flag) and like this it works and I’m able to input my email normally.

So the error I described above only appears when I use balena login and choose “Credentials” via menu.

Hey @turbopasi, I’m on Linux about to attempt to reproduce this. Which terminal are you running, and at which version?

Hey @dt-rush I tried on Ubuntu 18.04.2 LTS standard terminal &
on Windows Command Line 10.0.17763.1

Testing on linux using terminator terminal, this is not occurring for me on 11.3.3. I can type my email fine. It’s strange that this is occurring for both windows and ubuntu terminals on your side… Leads me to believe it’s not related to the terminal itself. Are you perhaps using ubuntu through the windows terminal?

@dt-rush No, we have Ubuntu set up on a VMware workstation on our Root Server. That’s were I tried in the terminal + the command line on my personal system seperated from the ubuntu one.

Since balena login --credentials works for us for now we are good :slight_smile: we do not need to use the menu variant.

Also I installed the CLI manually via zip package from the github page, if that is of any interest.

Also I installed the CLI manually via zip package from the github page, if that is of any interest.

Thanks for sharing this! Indeed I was able to reproduce the issue using the standalone installers on Linux and macOS. Oddly, the npm installation method does not seem to be affected by this issue, nor the standalone zip for version 10.17.5. I have created this CLI GitHub issue for further investigation and a fix:

1 Like