Auto connect of eth0 issues

This is the first time I’m seeing this issue, but for some reason my device does not want to automatically connect via eth0.
I’ve tried several different connections on my router side so I’m wondering if there is some configuration issue in my device, but I’m not sure exactly how to go about digging into the issue.

eth0: connecting (getting IP configuration) to Wired connection 1
        ethernet (bcmgenet), E4:5F:01:30:06:C0, hw, mtu 1500

It’s been in this state for a few days - trying to get IP information.
Any suggestions on where to begin?

This looks like an error related to DHCP configuration, so this would be a starting point. Maybe there was a change in the router config that is affecting the device? Without further context is hard to tell, but you could try to pinpoint the problem by connecting the device to a different network, for example


Thanks Ramiro, apparently the issue is at my switch - nothing to do with Balena.

Hi again @barryjump. That’s great to know. If you can take some time to share the steps you followed to figure out where the network configuration issue was that might be very useful to other users in our community.

Thanks again!

Actually it was pretty simple (though didn’t cross my mind at first). I tried other devices, including a desktop computer on the switch and got nothing. We just got fiber internet and apparently the modem doesn’t like the switch. Or the switch doesn’t like the modem. Not sure yet…

Oh, thanks for sharing that. Glad you figured it out.

1 Like