Artik 710 GPIO Failure

Hi All!

I’m trying to use resin on my fancy new Artik 710 and am having trouble getting and LED to blink!

I tried running the example artik-gpio-python but failed with an issue where the GPIO is apparently busy.

I tried following the samsung artik tutorial to control the GPIO running the simple-node-server i.e.:

root@0176368:/usr/src/app# echo 38 > /sys/class/gpio/export
bash: echo: write error: Device or resource busy

Any ideas? I would love to be able to control the GPIO, it’s a project requirment!

Thanks for any time and energy!


Hi! Our OS team is looking into it, hopefully we’ll have more information next week.

I looked into this and here is the output of the investigation.
As part of getting a board supported by resin, we also enable a LED blink feature. You can use the LED blink feature from the dashboard when your artik710 is up and running (there is a blink button next to your device online status label, when you are in your application page; or, there is a blink button you can use from the device page, right next to the Restart button). This is defined for the artik710 here:

So we do this for all the devices we support, you can see that here: So this just makes the kernel compile the leds-gpio driver, which is the driver that is preventing you to run the example.

If you still need to control these leds, you can do so by:

echo 1 > /sys/class/leds/led1/brightness


echo 1 > /sys/class/leds/led2/brightness

(and echo 0 instead to turn them off)

So in conclusion, it is just these 2 LEDs that you won’t be able to control by means of sysfs gpio. The rest of the available GPIO’s should be fine to use.