Air Quality Monitor - Installation fails (Grafana)

Hi there, I was following the tutorial

Tried it with two different Pi Zero W’s and also different SD cards, flashing on Windows and Mac OS, always resulting in the following issue after executing

balena push

The error is
[sensor] Step 8/11 : WORKDIR /usr/src/app
[sensor] Using cache
[sensor] —> 8f332c9e6c91
[sensor] Step 9/11 : COPY ./scripts ./scripts
[sensor] Using cache
[sensor] —> 49a7feee0c0c
[sensor] Step 10/11 : RUN chmod +x scripts/*.py
[sensor] Using cache
[sensor] —> e9e76446e216
[sensor] Step 11/11 : CMD /usr/src/app/scripts/
[sensor] Using cache
[sensor] —> c21b5aee0122
[sensor] Successfully built c21b5aee0122
[grafana] —> Running in 52ac67971536
[grafana] /bin/sh: 1: /usr/src/app/ Permission denied
[grafana] Removing intermediate container 52ac67971536
[Info] Uploading images
[grafana] The command ‘/bin/sh -c /usr/src/app/ “raspberry-pi”’ returned a non-zero code: 126
[Success] Successfully uploaded images
[Error] Some services failed to build:
[Error] Service: grafana
[Error] Error: The command ‘/bin/sh -c /usr/src/app/ “raspberry-pi”’ returned a non-zero code: 126
[Error] Not deploying release.
Remote build failed

Additional information may be available in debug mode. Prefix the command
line with DEBUG=1, i.e.:  DEBUG=1 balena ...
If you need help, don't hesitate in contacting our support forums at

For bug reports or feature requests, have a look at the GitHub issues or
create a new one at:

Any help appreciated I am really running out of ideas…

Ok, looks like versions 1.0.1 introduced the bug. They pushed 1.0.2 but I fail with the same error.
Switched to 1.0.0 and finally could upload the code to the raspbi :smile:

@kwjibo089 thanks for letting us know! I am not sure why this is still an issue with v1.0.2 but I’ve just pushed v1.0.3 that should definitely resolve it - take a look at the diff if you are interested to see what I did.

I would love to hear if you’re able to push v1.0.3 successfully now!