Windows 10 hangs on Starting

Windows 10 hangs about 10 seconds after starting the image process. The PC becomes unresponsive and I have to hard reboot. Etcher deleted the existing volume on the SD card but that is all. I have used etcher on this PC in the past but recently reloaded windows from scratch. Windows version is 2004 but I installed Windows 190x (can’t remember the exact version) on another HD and have the same problem. I have tried various versions of etcher back to 1.4.9 as well as the latest, 1.5.97 with the same results. Win32diskimager works.

Hello, welcome to the forums!

Windows 2004 is not supported for etcher, see https://github.com/balena-io/etcher#supported-operating-systems. We only support Windows 7 onwards.
As for Windows 10, it should be working fine there. Were you able to successfully run etcher on Windows 10 in this PC in the past? Also, can I ask what are the specs of your PC? We don’t have official minimum requirements as far as I know for etcher but if this is hardware that dates back to Win2004 it might run into trouble running electron based applications.

Sorry just realised you probably meant Windows 10 version 2004 … not Windows 2004 :smiley:

To answer your questions and provide a little more info…

  1. I haven’t updated my desktop in a few years. It uses an i7-4790K processor. And yes I was referring to the windows 10 version number.

  2. I have been able to run etcher on this PC in the past but it was probably before windows 10 version 190x. As I stated earlier I re-installed Windows 10 about two months ago but that would have been 190x, then updated to 2004.

  3. I am able to run etcher on my wife’s laptop. It has not had a fresh load of windows in at least two years and is currently running version 1809.

  4. I’m hesitant to add the following info but since I don’t know what may be important to you I’ll include it. My Dell XPS 15 (9550) also had the same problem. Around the same time I reinstalled Windows 10 on my desktop I also reinstalled it on my laptop. Most of my initial troubleshooting was done on the laptop. After having Windows hang I went back to etcher version 1.4.9 and it worked. Trying to find out which version caused the problem I progressively updated etcher until I reached 1.5.95 and it still worked even though it didn’t work before. Thinking I had found a solution I went to my desktop and went back to version 1.4.9 but it did not work. So while my laptop now works my desktop still hangs.

  5. I have tried both with an SD card slot and inserting the small SD card in a USB adapter.

In searching the forum for past failures like mine I have found several without any real resolution and they are not current. While I have workarounds I am willing to do any troubleshooting you would like.

Hi there, normally in these kinds of situations we would ask for you to capture the output from the Developer Tools in Etcher, by pressing ‘Control+Shift+I’ while flashing the image to SD or USB…but in this scenario if I understand correctly the PC completely locks up and in that case you won’t be able to grab a screenshot or copy/paste the logs. However, you do mention it makes it about 10 seconds into the process, so perhaps if you are very fast you can grab the screenshot or logs and write them to a file prior to it locking up. Otherwise, the only other things I can think of are some sort of internal hardware issue where the device driver panics, check for any BIOS / UEFI updates for the laptop, see if there are specific drivers recommended by the laptop manufacturer that need to be installed, or some other application conflict…Perhaps try disabling any Antivirus, Windows Defender, etc. Hope that helps.

I will try that tomorrow and get back to you.

Below is the log before windows hung.

gui.js:79021 _____ _ _
| | | | |
| |
| |
| | ___ _ __
| || / | ’ \ / _ \ '|
| |
| || (
| | | | / |
_
/ ____|| ||___||

Interested in joining the Etcher team?
Drop us a line at join+etcher@balena.io

Version = 1.5.97, Type = nsis
gui.js:129907 Wed Jun 10 2020 09:52:00 GMT-0700 (Pacific Daylight Time) Application start ({“packageType”:“nsis”,“version”:“1.5.97”,“sample”:0.1,“applicationSessionUuid”:“9ebc5b52-661f-4544-b987-3243aa3e642c”,“flashingWorkflowUuid”:“0c3da4a6-c0e4-419b-84dd-68d59da5e72b”})
gui.js:122609 Wed Jun 10 2020 09:52:02 GMT-0700 (Pacific Daylight Time) Open image selector ({“sample”:0.1,“applicationSessionUuid”:“9ebc5b52-661f-4544-b987-3243aa3e642c”,“flashingWorkflowUuid”:“0c3da4a6-c0e4-419b-84dd-68d59da5e72b”})
gui.js:122609 Wed Jun 10 2020 09:52:05 GMT-0700 (Pacific Daylight Time) Select image ({“image”:{“size”:2879389696,“name”:“2019-09-26-octopi-buster-lite-0.17.0.img”,“hasMBR”:true,“partitions”:[{“offset”:4194304,“size”:268435456,“type”:12,“index”:1},{“offset”:272629760,“size”:2606759936,“type”:131,“index”:2}],“path”:“C:\Users\ritch\Downloads\Raspbian\2019-09-26-octopi-buster-lite-0.17.0.img”,“extension”:“img”,“logo”:false,“blockMap”:false},“sample”:0.1,“applicationSessionUuid”:“9ebc5b52-661f-4544-b987-3243aa3e642c”,“flashingWorkflowUuid”:“0c3da4a6-c0e4-419b-84dd-68d59da5e72b”})
gui.js:122609 Wed Jun 10 2020 09:52:08 GMT-0700 (Pacific Daylight Time) Flash ({“image”:“C:\Users\ritch\Downloads\Raspbian\2019-09-26-octopi-buster-lite-0.17.0.img”,“drives”:[{“size”:32010928128,“isVirtual”:false,“enumerator”:“USBSTOR”,“logicalBlockSize”:512,“raw”:"\\.\PhysicalDrive3",“error”:null,“isReadOnly”:false,“displayName”:“F:\”,“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"\\.\PhysicalDrive3",“busVersion”:“2.0”,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:null,“mountpoints”:[{“path”:“F:\”}],“description”:“Generic- SD/MMC USB Device”,“isUAS”:false}],“driveCount”:1,“uuid”:“6588268f-406a-49f1-b921-8aee964d02b6”,“status”:“started”,“flashInstanceUuid”:“6588268f-406a-49f1-b921-8aee964d02b6”,“unmountOnSuccess”:true,“validateWriteOnSuccess”:true,“sample”:0.1,“applicationSessionUuid”:“9ebc5b52-661f-4544-b987-3243aa3e642c”,“flashingWorkflowUuid”:“0c3da4a6-c0e4-419b-84dd-68d59da5e72b”})
gui.js:122609 Elevating command: C:\Users\ritch\AppData\Local\Programs\balena-etcher\balenaEtcher.exe C:\Users\ritch\AppData\Local\Programs\balena-etcher\resources\app
gui.js:5613 0 devices, 0% at 0.00 MB/s (total 0.00 MB/s) with 0 failed devices
gui.js:122609 Wed Jun 10 2020 09:52:10 GMT-0700 (Pacific Daylight Time) SafeWebview loaded ({“event”:{“id”:1,“url”:“https://assets.balena.io/etcher-featured/index.html?etcher-version=1.5.97&api-version=2&optOutAnalytics=false",“method”:“GET”,“timestamp”:1591807930211.278,“resourceType”:“mainFrame”,“ip”:“104.31.82.157”,“fromCache”:false,“statusLine”:"HTTP/1.1 200”,“statusCode”:200,“responseHeaders”:{“access-control-allow-origin”:["*"],“age”:[“468”],“cache-control”:[“max-age=600”],“cf-cache-status”:[“DYNAMIC”],“cf-ray”:[“5a1499daaca3c995-SEA”],“cf-request-id”:[“0340be7ca60000c995f307c200000001”],“content-encoding”:[“br”],“content-type”:[“text/html; charset=utf-8”],“date”:[“Wed, 10 Jun 2020 16:52:07 GMT”],“expect-ct”:[“max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct””],“expires”:[“Wed, 10 Jun 2020 13:07:37 GMT”],“last-modified”:[“Mon, 01 Jun 2020 19:09:20 GMT”],“server”:[“cloudflare”],“status”:[“200”],“vary”:[“Accept-Encoding”],“via”:[“1.1 varnish”],“x-cache”:[“HIT”],“x-cache-hits”:[“1”],“x-fastly-request-id”:[“a59b33e0145f1ffc76a99a3c3cc972ce1dd496f4”],“x-github-request-id”:[“8A56:9AFF:AB779:C1CA8:5EE0D8C1”],“x-origin-cache”:[“HIT”],“x-proxy-cache”:[“MISS”],“x-served-by”:[“cache-sea4477-SEA”],“x-timer”:[“S1591807927.491111,VS0,VE1”]},“referrer”:"",“error”:“net::OK”},“sample”:0.1,“applicationSessionUuid”:“9ebc5b52-661f-4544-b987-3243aa3e642c”,“flashingWorkflowUuid”:“0c3da4a6-c0e4-419b-84dd-68d59da5e72b”})
gui.js:122609 Successfully connected to IPC server: etcher-server-780, socket root C:\Users\ritch\AppData\Local\Temp
gui.js:122609 Image: C:\Users\ritch\Downloads\Raspbian\2019-09-26-octopi-buster-lite-0.17.0.img
gui.js:122609 Devices: \.\PhysicalDrive3
gui.js:122609 Umount on success: true
gui.js:122609 Validate on success: true
gui.js:122609 Auto blockmapping: true
gui.js:122609 Decompress first: true

Hi,

  • I tried to reproduce this issue on my machine. Windows 10 Version 1903. And It is working fine.
  • I tried to compare the logs you shared with mine and it seems that your machines start to hangout once the flashing process is about to start.

I guess it could be a failing drive, poor driver support, or even application conflict.

I did some more testing. I went back to an older version of windows (1709) as well as etcher version 1.2 and had the same problems. Using windows 10 version 1909 I can successfully write a windows 10 image using rufus and I can successfully write a raspbian image using win32imagewriter using the same sd card in all cases. That would seem to rule out a failing drive. Since I have reinstalled windows 10 version 1909 and 1709 (separate hds) yesterday and this morning I do not have any extra software installed other than that needed to test. Since everything else seems to work I would not call that poor driver support but there does seem to be an incompatibility between etcher and my system.

One thing, one of the times it failed windows gave me a blue screen with a watchdog timer error. I still had to hard reboot the computer.

I have a workaround using win32imagewriter so I don’t need to use etcher but I am willing to spend time doing any troubleshooting you may want. I also know that this problem is fairly rare based on my search of the forum so I understand if you do not want to pursue this issue any further.

Hey, this issue seems very strange indeed. We are discussing internally and we will come back with some action items in order to better understand the underlying cause. Thank you for bearing with us! :muscle:

I’m willing to do anything you want. I’m a retired electrical engineer but spent most of my career writing realtime embedded sw including some minor driver work. Being retired I have a fair amount of free time. I’ve also written some Win apps to display data from the custom computers since the debug environment was nonexistent. I’ll have to admit they were quick and dirty using the old MFC. It’s been a few years and I’m not fluent on current processors but I understand the concepts. Even though it seems to be something like a subtle timing issue I have embarrassed myself enough over the years to learn not to exclude any possibility.

FYI: I’m getting a new USB sd card reader tomorrow to see if that helps.

Hi there – thanks for the response and the offer of help! We’ll let you know the outcome of our discussions, but definitely let us know how the new USB card reader works out for you.

All the best,
Hugh

I’ve got bad news and good news. The new sd card reader did not help but the good news is I can now write images to a usb drive. I installed Ubuntu on an old drive but was having problems imaging a USB drive so decided to go old school and burn a DVD. But I couldn’t get the install to work so I moved the DVD to another SATA port. My motherboard has some SATA channels that interface to the CPU and some that go thru a separate controller and the DVD was on one of those. When I moved the DVD to the direct interface I was able to install Ubuntu. I then tried Etcher from Ubuntu and it worked. When I went back to Win, Etcher also worked. Don’t ask me why but the DVD seemed to be causing the problems, maybe messing with the interrupts? To be complete I would put the DVD back on the other interface to see if the problem reappears but I’m tired of fighting it for now and the MB SATA connectors are hard to access. If I try I’ll let you know the results if you’re curious.

Hey there! Thanks for the detailed update. We’re glad Etcher is working for you now, and definitely let us know if you confirm that the DVD drive was the culprit, as it’d be something we are interested on investigating further!

I couldn’t leave it alone. I moved the DVD back to the other SATA interface and etcher failed. I put it back and etcher is flashing as we speak. I don’t have another DVD drive (yet) to try out to see if it is the DVD drive or the MB/Win. My mother board (ASUS Z97 Extreme6) is about 5 years old running a gen4 i7 processor. I’m too old to play games (slow reaction times and bad internet) so I don’t need lots of power. There are two SATA interfaces. One is off the Intel Z97 and has 6 channels. The other is off an ASMedia ASM1061 and has 4 channels. It is when I connect to an ASMedia channel that the PC hangs when running etcher. When I go back to the Z97 it works.

Hi, have you tested this on both windows and ubuntu for example? Or just on windows 10?
Also, waiting for you to test another DVD drive so that we have more data on if it’s drive related or motherboard.

Linux would not boot with the dvd drive connected to the asmedia sata channel. I’ve ordered a new dvd drive which will take a couple of days to try to isolate to the drive or mb

Ritchie Christian

I received the new dvd drive and windows still hangs when connected to a ASM1061 SATA channel. I have even tried another cable just in case. At this point I would say it is either a MB hardware fault or design flaw that is exhibited under fairly unique circumstances. It’s interesting that this secondary SATA interface affects the USB interface. I would not have thought the DVD drive connected to a specific SATA interface would cause a fault imaging an SD card. No knowing the MB or driver designs this is all the further I can take it.

Thanks for your patience. And for those reading this, don’t discount the possibility of a PC problem when etcher doesn’t work. I sure didn’t expect this outcome.