Using RPi camera module on beta Raspberry Pi 3 64 bit OS

Has anyone had any luck getting the Raspberry Pi camera module working on the beta Raspberry Pi 3 64 bit OS? I’ve tried the steps shown here:
https://www.balena.io/docs/learn/develop/hardware/i2c-and-spi/#raspberry-pi-camera-module

In my app I’m using OpenCV’s python interface to grab frames from the Pi camera. Using a USB webcam works fine but I get the following error with the Raspberry Pi camera module:

VIDEOIO ERROR: V4L: can't open camera by index 0

I wanted to check here since all the examples seem to be using the 32 bit OS.

Hey,

Just to let you know that we are looking into this, and will hopefully have some news soon.

Thanks for the update, Rich! I’m looking forward to learning about what you find!

For now I’ve moved to the RPi 3 32 bit OS and the camera module is working as expected.

Hi @ericvb ,

For my testing setup I used this project which uses opencv to read a frame from the camera and print some info about it (width, height, channels).
Using the current 64bit production version of balenaOS for the pi3 (2.38.0+rev1) indeed the camera module doesn’t work.
I also tried the 2.43.0 rev1 64bit version which hasn’t been released yet, the outcome was that it works as expected!