Update not progressing beyond "Update successful, rebooting"

I have tried to update my device https://dashboard.balena-cloud.com/devices/5ba8763485e3f982b0410a6c66343064/ to 2.47.1 and it all seemed to progress as normal but it hasn’t got beyond “Update successful, rebooting”, despite starting the update process a few days ago. Is there anything that can be done to make the device progress beyond this stage of the process?


Hello, it looks like something might have gone wrong as the device rebooted itself after the update Did you also update the OS to any other device in the same application or network, was that successful?

Hi, thanks for the fast response.
Yes 2 other devices running the same code (and hardware) have sucessfully accepted the update. I have an identical setup on my desk I use to test each update on.

The device is running a LoRaWAN gateway on a remote site so we don’t have any other balena devices on the same network. We can remotely power cycle the device, but all other management is done through Balena.

Could you try power cycling remotely then? Unfortunately it does not appear online for us, and without another device in the same network it could be hard to reach it. Lets see if it happens to connect after a reboot so we can try sshing into it to have a look.

I’ve tried to power cycle it but that seems to have been the final straw. Before it was showing as online in the dashboard I can see, now it’s just showing as offline. I can’t ping it from the other (non balena) device on the network and its power consumption implies that it hasn’t attempted to boot.

Thanks for trying to help, but I think this one will require a physical visit at some point in the future to get to the bottom of. I suspect SD card issues.

Or maybe it does live after all. It’s now showing as “connected to VPN” “No recent API configuration”.

Hi @pjb304, we’ve taken a look at your device and I believe we resolved the issue by clearing the contents of /var/lib/balena, updating the device supervisor and restarting the balenaEngine.

We observed that balenaEngine got in a corrupted state. This is probably because of SD card failure. Doing the device diagnostics check we see test_write_latency failing. Slow disk writes could indicate faulty hardware or heavy disk I/O – which again point to SD card issue.

So as you also noted, it’s best to replace the SD card sooner than later.


That’s great thank you :slight_smile: .