Unable to delete application.

Hi folks.

When I tried to delete the application CNCMachinePi4 from my account I receive an error. I have tried both via the web and the CLI:

$ balena app rm CNCMachinePi4  --debug
[debug] new argv=[/home/jimsy/.nvm/versions/node/v14.9.0/bin/node,/home/jimsy/.nvm/versions/node/v14.9.0/bin/balena,app:rm,CNCMachinePi4] length=4
? Are you sure you want to delete application CNCMachinePi4? Yes
BalenaRequestError: Request error: [object Object]

BalenaRequestError: Request error: [object Object]
    at Object.<anonymous> (/home/jimsy/.nvm/versions/node/v14.9.0/lib/node_modules/balena-cli/node_modules/balena-request/build/request.js:190:27)
    at Generator.next (<anonymous>)
    at fulfilled (/home/jimsy/.nvm/versions/node/v14.9.0/lib/node_modules/balena-cli/node_modules/tslib/tslib.js:111:62)
    at processTicksAndRejections (internal/process/task_queues.js:93:5)

Additional information may be available with the `--debug` flag.
For help, visit our support forums: https://forums.balena.io
For bug reports or feature requests, see: https://github.com/balena-io/balena-cli/issues/

I have enabled support access to the application: https://dashboard.balena-cloud.com/apps/1699940


Hey @jimsynz

Happy eventually consistent Monday and thanks for bringing this up Jimsy :smiley: !

We seem to have caught this in a couple of other places, and have a fix that should prevent this from happening. The dashboard devs are taking a look and we’ll have a fix deployed soon!

Minor correction - we have a fix that will help getting more information as to why you cant delete.