Unable to connect to "archive.raspberrypi.org" and multiple --build-arg flags matters

I am new on docker with raspberry pi. I just write a “Dockerfile” to start to build the first project. However, I get lots of shit in the beginning.

The first issues is unable to use multiple --build-arg to build it. I seen the similar issues. Currently, I reduce only one --build-arg flag to build and it get started.

But, the second matter is on “RUN apt-get install package”. I cut the phrase of error to paste here. It seems the matter on network.

Err http://archive.raspbian.org jessie InRelease
Err http://archive.raspberrypi.org jessie InRelease
Err http://archive.raspbian.org jessie Release.gpg
  Unable to connect to
Err http://archive.raspberrypi.org jessie Release.gpg
  Unable to connect to
Reading package lists...
W: Failed to fetch http://archive.raspbian.org/raspbian/dists/jessie/InRelease  

W: Failed to fetch http://archive.raspberrypi.org/debian/dists/jessie/InRelease  

W: Failed to fetch http://archive.raspbian.org/raspbian/dists/jessie/Release.gpg  Unable to connect to

W: Failed to fetch http://archive.raspberrypi.org/debian/dists/jessie/Release.gpg  Unable to connect to

W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
E: Unable to locate package upgrade

I run on raspberry 1B+ with docker image-“resin/raspberry-pi-debian:latest”.

This is the output of “docker info”. Wish some help. Thanks.

Containers: 1
 Running: 0
 Paused: 0
 Stopped: 1
Images: 17
Server Version: 18.05.0-ce
Storage Driver: overlay2
 Backing Filesystem: extfs
 Supports d_type: true
 Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
 Volume: local
 Network: bridge host macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 773c489c9c1b21a6d78b5c538cd395416ec50f88
runc version: 4fc53a81fb7c994640722ac585fa9ca548971871
init version: 949e6fa
Security Options:
  Profile: default
Kernel Version: 4.14.30+
Operating System: Raspbian GNU/Linux 9 (stretch)
OSType: linux
Architecture: armv6l
CPUs: 1
Total Memory: 243.5MiB
Name: retropie
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
Live Restore Enabled: false

WARNING: No memory limit support
WARNING: No swap limit support
WARNING: No kernel memory limit support
WARNING: No oom kill disable support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
WARNING: No cpuset support

I found the cause.
Why I run it unsuccessfully? The matter is on proxy. I just setup a new proxy to download the package via apt-get. Due to the old proxy, “apt-get” unable to get the list. So, it shows up the error message.

In addition, I found the matter on “multiple --build-arg”. The problem is on “-” this symbol. I had pasted a long command line to a notepad. When I copied from the notepad to the terminal, it automatically transformed “-” as an unknown character.

All of them are my wrong. Complete the answer in here for anyone able to refer.