Troubleshooting Local Mode - Balena CLI Logs

How about ping to ? I can ping your laptop and ssh root@ -p 22222 from the device so the port is available on the devices external address.
If it is not firewall stuff I can only imagine that there might be an address conflict in the network with another host occupying the same address.

Hi @samothx,

Tried a few things this morning when i got in. The image attached shows you my actions in order

Powered down BBG
Ping’d the IP address of the BBG to make sure there is no network conflict
Tried ssh root@… and it did connect to the point of verifying host but timed out afterwards
Retried ssh root@… and this one timed out.

I’m going to try a different iP address for the BBQ to see if there is any change in the behavior or if there is some other network conflict.

Hi there, and thanks for the update!

Please keep us updated on the results of testing a new IP address.

BalenaCLoud starter account. I have put my device into Local Mode. I am on a windows 10 laptop (Wired eth for BBG and laptop on the same switch). I have console port access to BBG and can login via root. I have confirmed that on the BBG the eth0 has a valid IP. I can ping out from the BBG.

BBG Balena versions:
Host OS BalenaOS 2.29.2+rev3 - DEVELOPMENT
Supervisor 9.0.1
Balena CLI version is 11.6.0 (using Windows installer)

I can ssh into device using balena ssh .local. I have nothing running on the device itself other than the base Host OS.

@xginn8 THe IP address didn’t change even when i moved it to a different port in our network. I gave up on the BBG and tried a Raspberry PI 3. I tried the scan command and that worked correctly (never worked with BBG). I’ve successfully ssh’d into the device (using Putty and WIndows 10 command ssh) and am trying the logs command right now. It would seem something in the BBG base configuration or software is not working. I noted both the Supervisor and base oS versions are quite different between the 2 platforms.

I’m not sure how to tell if the logs command is working as it has been stuck on that command for a long time (> 3 minutes). Next I’m going to try a balena push as this was where I want to start playing with the device.

Hi again @vdsilva,

If you are using DHCP and that IP was just reassigned to the same MAC on a different switch port, you may want to try setting up a static IP that is definitely not occupied. You can read more about that from the balenaOS side here.

@xginn8 I’ll give the static IP a try and if that doesn’t work I’ll proceed with the RPi3 for what I need to do and develop. Thanks for your help and @samothx as well!

Great, please keep us updated on how that goes!

@xginn8 The static ip works on BBG. I’ll follow up with our IT on why that is. Thank you very much! Consider this solved!

I have marked that post as a solution for posterity. Thank you for reaching out!