Traefik on my project

Hi everyone,

I was wondering if anyone tried this.

I am trying to deploy Traefik on my rpi3 project but I keep having the same error. My guess is that error comes when the Image is not on the right platform

2019/10/12 21:32:20 command traefik error: field not found, node: entryPoint

Do I need to specify something on Dockerfile or add a flag on the docker-compose file?

From what i can read from Traefik, it’s already packaged for armv6.

FROM traefik

RUN apk --print-arch

COPY traefik.toml /etc/traefik/traefik.toml

I found my hint here : How to deploy official eclipse-mosquitto container on a raspberry pi as a service in a docker compose file?

even though the arm image is available, I dont think the cloud builder is using that.

found this path but still no cigar

@leross welcome to the forums and thanks for posting! Could you share what you did to resolve the issue? What was wrong with the config file in the end?

It was the config file all this time. The compatibility was broken between traefik v1 and v2. When I tried to start with no config file on my own, it went further.