SSH was working, permission denied on git push today

Attempting to update my code. Git push worked yesterday, getting a SSH permission denied today with the same key. Tried generating a new key and adding it, still get permssion denied

Hi @PeterSprague! I just tried adding an ssh key and pushing with it and it worked fine for me, so it might be something in your ssh configuration. What OS are you using? Have you tried running ssh-add ~/.ssh/<key filename> before pushing? (Maybe your ssh agent is not using the correct key?)
Also, what does git remote -v show on your repo folder?

1 Like

Thanks for the confirmation. Will concentrate on my end.

Fedora 26, ran ssh-add, git remote resin is correct.

It worked yesterday, now doesn’t work

Opened another terminal tab and git push resin worked.

Hey there,

That is very weird, but I’m glad you sorted it out. Maybe worth looking at your SSH agent settings?

Agree, but it cleaned up whatever was ailing. Been working fine last few days, so really don’t understand the glitch unless I had