SSH issues when using git push balena master


I’m new to Balena and I’m running into an issue. When I enter the command “git push balena master” I get the ssh error below:

ssh: connect to host port 22: Connection timed out
fatal: Could not read from remote repository.

According to my cloud settings, I’ve already added an SSH key into the account and to my knowledge, there isn’t any firewalls or anything blocking that port. Can anyone provide help on resolving this?

That’s strange, indeed seems like the network is acting up. Can you try to run ssh -v and paste the output here? It should not connect (with an authorization error), but we should get more diagnostic information.

Also, have you tried out the balena command line interface?

With that you could use balena push Appname and no SSH setup is required. That might help to unblock you.

I downloaded the Balena Cli and used the command provided. That seems to have solved my issue regarding this topic. Thank you for your help.

Sounds like there might have been a temporary network problem or a hickup on our side. Have you tried using git push again ? Did the problem occur over an extended period of time ?


It must have been a network issue, as I was unable to recreate the error. Thanks for your help.

Thanks. Feel free to start another forum thread if you face any issues.