Socks Proxy noProxy Format

Hello,

We have IoT devices in regions that prevent Balena VPN from establishing connection. In order to get around this we have a socks5 proxies running. The proxy is working great to enable Balena VPN connectivity but I would like to disable proxying some services that utilize AWS Global Accelerator. Based on the documentation, I can supply a list of addresses not to proxy via noProxy: Balena API Proxy

If I place an address with a wildcard prefix, it causes Balena VPN connection to fail (devices show heart beat only). If I remove just the noProxy with empty list, the VPN connection is restored.

Below is essentially what the body of the request looks like. We have a number of APIs at different subdomains that I’d like to bypass the proxy (files.test.company.services, service.test.company.services).
Am I using noProxy incorrectly?

{
  "network": {
    "proxy": {
      "type": "socks5",
      "ip": "SOCKS_PROXY_ADDRESS",
      "port": 1080,
      "login": "SOCKS_LOGIN",
      "password": "SOCKS_PASSWORD",
      "noProxy": [
        "*.company.services"
      ]
    }
  }
}

Hi @adamp,

I was looking at the documentation link you pointed out, and as I see we allow a list of IP/subnet not hostnames. Ref from the doc below:

The “noProxy” setting for the proxy is an optional array of IP addresses/subnets that should not be routed through the proxy. Keep in mind that local/reserved subnets are already excluded by balenaOS automatically.

Link: Interacting with the balena Supervisor - Balena Documentation

Can you try a specific IP and see if that lets you establish the connection?

Regards,
N

Hi there, can you try specifying your proxy endpoint IP as well as the wildcard exclusion:

The above project which automatically configures a device by excluding the proxy IP itself, to prevent a loop.